Stuck Notes Inside of Cubase's Key Editor & Expression Map assignment (long notes)

Hey all, I’ve dealt with a bug that I’d like to solve involving Cubase’s Expression Map and MIDI editing with the mouse inside of the Key Editor. I’ve made a short video demonstrating this:

Basically, when acoustic feedback is turned on and you are sliding a note up or down with the mouse inside of the key editor, it will trigger a never ending note. This only happens when the instrument track is assigned to an expression map AND programmed as a long/sustained articulation. This doesn’t happen when the instrument track doesn’t have an expression map assigned or a short/staccato type articulation. I’ve also confirmed this bug with Cubase 11 and 12.

Does anyone else feel my pain here? Any solutions that you’ve found?


  1. Create a new instrument track
  2. Assign an expression map to the instrument track
  3. Record or Program in some MIDI notes on instrument track.
  4. Inside of Key Editor window, assign a long/sustain type of articulation such as Strings Long or Flute Sustain in the sample library that you’re using. (in my case, any Kontakt instrument with a long articulation will do).
  5. Now, slide the note up or down to a playable pitch that the instrument can do with the mouse by click and dragging it. Or try holding down the “alt” button and click-drag note to copy and paste the note above or below.
  6. I hear a feedback, never-ending stuck note until you press the panic button or MIDI-Reset button.

My Specs:
Cubase 11.0.41 & Cubase 12.0.0
Mac OS 10.14.6 Mojave
Mac Pro Intel Xeon 12 Core 3.46 GHZ
3rd Party Libaries included in video demonstration: 8dio Claire Flute, Spitfire Albion IV UIST Brass Hi, CSS Viola, Spitfire Chamber Strings Celli, 8DIO Insolidus.

1 Like

Yep i have the same issue. So annoying! Did you find any fix?

I also have stuck notes in expression map. It doesn’t matter if I have moved the notes or whether they are short or long. Pretty much I have to start playback and find a point where the note stops . . .then I stop playback. I tried your method to unapply the expression map, but the notes kept sounding. Also, I have some bugs within the editing of the expression map where I add or change names in the map and save, but the edits do not appear even though I unload the map and reload etc. Lots of bugs here and hope they put this on the list for the next fix.

edit: I found overlapping mapping events. When I fixed those then the only problem I had was a stuck note on the last expression map event which stopped once playback was stopped. Still a bug, but much less onerous. So check for event overlaps for sure.

(later) I haven’t tested yet, but I’m wondering if stuck notes might be a result of overlapping MIDI events in which case using the MIDI-functions-delete overlaps command might be worth a try. Unrelated, after shut down and reboot my stuck note problem seems to have gone away.

It’s working fine here, both directions and attributes, tried with and without empty first slot, i never get hanging notes

Cubase 12.0.52 on Ventura 13.1, same computer as yours, tried with instrument track on Synchron and Areia, also tried with midi instrument and VEP7.

It all works as expected

Yes, I’m having similar problem with Komplete Kontrol + Emotive Strings on Mac with CB 12… moved and copied some midi notes… and notes are hanging - really weird… Cakewalk (Sonar) had a KILL button, wish Cubase did. And I thought you could also run a script to find possible missing Note OFF data?? Only thing I can do it close project. But then it happens again. Guess I’ll have to redo the entire midi track?? Unless someone can help with a solution.