'Stuck' notes upon changing velocity data

Hey there!

I’m having an issue which I’m sure has quite an easy fix but I can’t for the life of me seem to find the right box to check/uncheck.
Whenever I’m editing instrumental parts (in this case: Cinematic Studio Brass, trough Vienna Ensemble Pro 7) in Cubase (11 pro) and I edit the velocity of a note in the key editor that note just stays on until I press play and the playback comes across that note that was previewed (and thus was stuck).
Any ideas?

Thanks in advance!

A short reply to get rid of hanging notes: menu MIDI → Reset
Don’t know what’s the cause of your instruments missing the NoteOff message from Cubase. I don’t know if it still works the same way in Cubase: Cubase did not actually send NoteOff messages but rather NoteOn with Velocity=0 to stop a note from playing. IRC way back in time there used to be an option whether NoteOff should be sent or NoteOn with Vel=0 but this is no longer there.

On the other hand: VST might have a completely different way of transmitting NoteOn/Off information, so…

The midi → reset does work, but I’d rather not be pressing this after every time I change a velocity.
Is there a way to check if cubase does indeed send this 2nd signal that is supposed to be killing the sound?

The only reliable way I can think of is to use a 3rd party MIDI event viewer. There are a number of free ones available for both Mac and Win.

Let’s start to do some detective work to narrow in on the possible cause:
You wrote “Whenever […] I edit the velocity of a note in the key editor that note just stays on”

  • How do you edit the velocity? Graphically in the lower velocity lane by drawing in a new value or through the info line by typing in a new value?
  • Do you have “Accoustic Feedback” enabled? If so, disable it temporarily. Does that get rid of the stuck notes?