Stuck VSTAudioEngine when loading playback templates

Hey there,

I find that about half the time that I try to load my playback template using Kontakt instruments, Dorico gets hung up while loading the samples into RAM. I can see this is the case because when my template is fully loaded, it takes about 25gb of ram. When Dorico gets hung up, however, my RAM utilization caps out at about 10gb. This tells me that the audio engine is no longer loading samples into memory. My playback buttons stay inactive indefinitely.

Does anybody have a solution for this? The only thing that works for me is to end the Dorico and VSTAudioEngine processes in the task manager and try again.

Thanks for any help!

I don’t have any great insights to offer, I’m afraid, but if you do Help > Create Diagnostic Report and attach the resulting zip file here, @Ulf and I can take a look and see if either of us can come up with any bright ideas.

Well, I’ve heard about similar cases in the past. Apart from the diagnostics I want you to do following : Download the free utility Process Explorer from Process Explorer - Sysinternals | Microsoft Learn and when the audio engine seems stuck, do a right click on VSTAudioEngine in that list in Process Explorer. From the pop-up menu select Create Mini Dump (or similar, but not a full dump). The resulting file please zip up and attach to a reply here. Additionally, I’d like you to create two consecutive dumps so I can check if it is really stuck at the same place. Thanks

Hi @Ulf, thank you for looking into this for me. I apologize for my late response but I was away from my computer for a few days.

I’m attaching the diagnostics folder as well as three VSTAudioEngine minidump files: two from where the engine was stuck, and one from when it successfully loaded the Dorico project. I thought that last one might be useful to you as well.

You’ll have to download the files via DropBox since the .zip is too large to attach here. Please let me know if I can provide any more help.

And thanks again!

Thanks for the data. I need to be at my Windows machine in order to analyze, will come back later…

Hi @Tyler_Pedraja , as I expected, Dorico’s audio engine’s main thread gets blocked by Kontakt, so it is Kontakt to blame on this behaviour.
What are your options? First, check and see if a newer Kontakt version is available. Second get in contact with Native Instruments and file a bug report with them. Provide them along the two mini dumps you also sent me and then hope that Native cares and fixes the problem.

1 Like

@Ulf Well certainly that’s not good. Thank you for checking into that for me. I’ll put in a support ticket with Native Instruments and see how far that gets me… Strange that I haven’t heard of others having this problem —I’m sure that plenty of Dorico users use Kontakt, too.

I’ll update this thread if I make progress with NI. Thanks again!

Sure, lots of people use Kontakt together with Dorico and mostly it is working fine, but as I mentioned in my first comment, occasionally users report exactly that problem here in the forum. I think it is more likely to happen, the more Kontakt instances are loaded, but its just a guess. Only Native will be able to tell.

1 Like

Hey guys, I just wanted to update this thread with Native Instruments’ response in case anybody else comes across this issue. NI Support said:

Your support tool info shows that Dorico is crashing due to a couple of things. There are two system files that appear quite a few times in the Windows error log. These files are VCRUNTIME140.dll and ntdll.dll. They are part of the visual design studio redistributable.

The following steps can usually fix these kinds of issues.

  1. Make sure all of the latest Windows Updates are installed by running this mini tool:
    Download Windows Update MiniTool - MajorGeeks

  2. Make sure all the Redistributable packages are installed and not corrupted by running this mini tool:
    Download Visual C++ Runtime Installer (All-In-One) - MajorGeeks

You may also want to go into Kontakt’s options and disable Usage data.

I’ll report back if these steps fix the issue.

1 Like

It seems to me that the last of these options – disabling the transmission of Kontakt’s usage data – is the one that’s most likely to help.