Studio setup/Audio System settings changes driver even when "Cancel"

Hi!

If I, by mistake, open up Cubase 11 without first starting my Motu interface (828ES), I will get a pop-up for chosing (other) driver.

If I chose to click “Cancel” here and close Cubase at this stage and open up Cubase later, it has still selected “Generic Low Latency” driver automatically, even though I clicked Cancel!!

For me this is a bug… Cancel means quit, stop, do nothing … and the selected driver should still be the Motu Pro Audio driver I had selected prevoiusly!!

The natural work-around is of course to start the Motu interface first or at this stage, and then wait for it to intialise and select the correct driver, but still…

Should not Cubase cancel the select driver operation and remember the previously selected driver?

/Hackej

Oh the humanity!
Fortunately, there is a solution for this calamitous “bug”.
Step 1. Select the correct driver.
Step 2. Don’t forget to turn on the device before starting Cubase.
Crisis averted.

I think it MUST have a driver, so even if you cancel, it defaults to the GLL driver.

Can you read the message? the generic low latency driver is the only one that is always available… if you cancel the message you cancel the selection of any driver so it falls back to the default… and guess what the default is GLL

Hi!

Thanks for the replies…

The reason it is a somewhat new and odd behaviour for me is that when using my older Motu PCIe based solution, the drivers where always there, regardless of if Motu interfaces was on or off.
And I thought that in this time and age it would be possible for similar solution also for newer interfaces although connected using USB.

But as noted…of course… turn on device first or select correct interface during start up!

/Hackej

Your MOTU-PCIe card (the real audio interface card) was always there… so no need for default drivers or switching them automatically

Hi!

Yes, and the solution for the Motu 828ES drivers is that the drivers are not available by-design (intentionally), I checked with Motu.
So it could work in the same way in this (use) case for newer drivers if the design was different.

/Hackej

my Apollo USB shows the same behavior… but I know my fault… turn it on, wait some seconds and select the right driver… problem solved

Hi again!

Yes, if you start Cubase before the audio interface you can wait for the drivers to be initiated and select the correct driver.

But then Cubase has also lost the the settings for the Audio Connections, so I also have to go in and re-select presets for Inputs and Control room ( I have curretly no outputs selected so those settings are not affected).

So in my view these are unnecessary steps and a step back regarding user experience.
Technical progress should mean improved user experience rather than the opposite!
And I know I sound like a “grumpy old man”…, but it is a little bit annoying as it takes some time before Motu is fully initiated and drivers are available.

And I am positive that this could (probably) be solved in some way.

Cubase could for example keep track of (and remember) two different configurations when initiating/loading drivers:

  • The Custom driver - i.e. my chosen audio driver with associated settings
  • The Default driver - the backup driver that cubase may use if/when no other driver is loaded.

And if the custom driver is not available when Cubase is initiating it could show the pop-up asking me if I want to:

  • Load another driver/the default driver or
  • Wait for the Custom driver to load/be ready. And as soon as my custom driver is loaded all settings are automatically as I want it to be.

And if I decide not to start my audio Interface at all I can still use Cubase for checking project info, notepads, used VSTs and plugins or whatever, when my intention is not to play or record any music, which sometimes is the case. But I will not get any sound.

And the next time I start Cubase it will still (try to ) load my custom driver., and not the Default driver.

So I actually wish this could be looked into!!

Regards
/Hackej