Success

Just did an actual session with a singer-songwriter- she laid down a guitar track and overdubbed a couple vocal tracks, then I overdubbed some violin. Things went smooth, smooth smooth. I can see how the fact of being remote will be easy to forget during a session as long as we don’t try to sing together, which is hilarious what with the latency delay! (like any voip)

Session was about two hours long. I’m using VST Connect Pro on a Win 10 machine, she was on a Mac. We were using the latest versions musicullum posted in links in this forum. https://www.steinberg.net/forums/viewtopic.php?p=974897#p974897

and younhave any latency…cos I am trying with a client and he can lie¡Sten perfect but I have like 2 seconds latency

There was no latency audible. You’re not using speakers on either side are you?

do not engage track monitor. You can hear Performer at any time via master.

Hi Steve - wonder if you could help

I managed to tether the Laptop and got Connect and Performer running - not an easy task getting them to ‘talk’ to each other but I managed.
The only thing I don’t understand is that I had the three channels off - VST1, Mic, Instrument, yet I could still hear my guitar etc in the cans’ it made no difference? it could only be turned down by the Master but also everything else went down with it? how can this be corrected please?

To play back tracks do I have to set them up like this - Input VST Connect, Output Stereo 1+2 and then use the VST Mixer to re-mix the levels etc…

You are probably trying to do too much configuring, but it’s hard to say from here. Playback works exactly as it does in a regular session, the system uses skeuomorphic design- it’s modeled after an actual studio. Engineer in the Control Room wearing headphpones, performer in a recording booth wearing headphones. Conceptually everything follows from there.

Whatever your experience has been, you should start from scratch with an empty project by running Setup VST Connect from the VST Cloud menu in Cubase. Do not turn on any track monitors. and make sure that you are not monitoring an input channel via your audio interface.

You have to read the manual, sorry, I know many people are annoyed by hearing that, but in this case you must. I don’t mean looking something up when you are in trouble, but reading it from end to end- it’s not all that long. If any images don’t match current versions don’t worry, the concept is the same.

It sounds like you don’t understand how the routing works, so study the explanation and images at http://connectvst.com, don’t skim it, and don’t use it as a reference only when things go wrong, if that’s what you’re doing.

Here’s couple hints, and I’m just repeating what I’ve read here-
VST Connect handles everything
No track monitors allowed,
No direct monitoring of the audio interface inputs.

Hi Steve
so by no direct monitoring do you mean not selecting the ‘speaker’ icon on the recording track? and if so i now don’t get a level meter or do I just have to press record and adjust whilst its recording, then once the level is ok, delete the audio and start recording properly.
would this cure the Monitor problems im having?

oh, and will I need to send the performers this new version of VST Performer.

Andy

Do not engage track monitor for Performer tracks. You can hear the Performer at any time via the VST Connect Master plugin in the control room/monitor section. If you use headphones, you should move that plug to the headphone monitor.
You will not see levels of the Performer while chatting or recording other than within the Performer Monitor section. Unfortunately, we cannot remote control hardware input gains, as there is no common interface for that. So you will have to advise the performer to do that, referencing the Performer channel meters.

How do the Performers Monitor?
I have set up my laptop as the ‘performer’ Im using a Steinberg UR824 for my Audio interface (no latency what so ever :slight_smile:) however my guitar is plugged into input 1 of the UR824 and also comes out of the phones (obviously) when the track is played I can only alter the volume of the guitar against the track by turning down the input level on the UR824… Do I have to select Steinberg 824 in and another sound source for the output to correct this? is this what everyone needs to do?

It depends if you use direct monitoring on the interface. If you do, you will probably not want to hear the channels with the faders (Performer Monitor) and mute those. However then you will have to maintain the mix in the UR824 DSP Mixer I guess.
In order to record, your Performer channels have to be set to the according sources (top of the channel), this can also be done remotely by the Studio to aid not so experienced useres. But VST Connect cannot access your UR824 other than that, this also goes for Input Gains, which you should not use for monitor mix but set to usable levels. So: either direct monitoring with DSP mix and mute Performer channels, or use the latter to mix.

A bit confused with what you mean, Direct monitoring on which interface? I will have a play around with what I think you mean and let you know…
This is the only thing I now need to sort as it’s difficult to get a balance when the signal is coming direct from the UR824 - and I know this will be an issue with any of the Performers I aim to be recording… but as I say im not sure what you mean in your reply. will have another play :slight_smile:

“when the signal is coming direct from the UR824” - right, that’s what I mean by “Direct Monitoring”.
But you were talking about the Performer, that is what I was refering to. Now you talk about “recording performers”, so that calls for confusion :slight_smile:
Maybe you could rephrase your questions?

“when the signal is coming direct from the UR824” - right, that’s what I mean by “Direct Monitoring”.
But you were talking about the Performer, that is what I was refering to. Now you talk about “recording performers”, so that calls for confusion :slight_smile:
Maybe you could rephrase your questions?

sorry…too much, this explodes :slight_smile:

Ill try :grinning_face_with_smiling_eyes:. As a performer - I plug my guitar into the interface along with some headphones… I have VST performer loaded and connected. The Guitar can be heard in the headphones (obviously) The fader for Inst is off because the volume of the guitar can already be heard. The click and backing tracks are coming through and can be adjusted by the Studio fader (and Master). However, my guitar is too loud so the only way I can turn it down is to reduce the input on the interface - but this means a quieter signal is being recorded. I guess there’s nothing that can be done about this as the UR428 along with the majority (if not all) interfaces does not have a direct monitoring switch on/of enabling the user to stop the guitar going straight into the headphones and enabling him to use the inst fader and also take advantage of the Reverb, comp etc…or is there another way?

Thanks, that is very precise :slight_smile:
Sorry, no time for user support for UR824. But there should be software dspFx or the like where you can set direct and “indirect” routing/levels.
maybe this: https://www.steinberg.net/forums/viewtopic.php?t=68270

It’s not necessarily my 824, it would be a problem with any audio Interface the ‘performer’ would use, I’m just pre-emptying the issues I know the performer will have as no ‘direct monitoring option will be available as they are not using a DAW just their interface with VST Performer… How has other users got around this problem?