Suddenly I Cannot launch Cubase 12 or Activation Manager- Fixed

I tried to open Cubase in Windows 11 and it freezes when checking for licenses. I tried to open Authorization Manager and it freezes on a blank opening screen. I’ve tried uninstalling and reinstalling both programs several times, both through download manager and manually, as well as elicenser, but nothing helps. Any suggestions?

Have you restarted the computer?

1 Like

Thanks for responding. I restarted the computer every time I uninstalled an app. I actually shut it down and waited 15 seconds before restarting.

The strange thing is that when starting Cubase, it hangs on “Checking for Licenses” in the splash screen, but I never get a massage that there is a problem with the license.

I just upgraded my motherboard, CPU, and RAM and did a fresh Windows 11 install. Cubase worked fine after that for a few days. I may have to try reinstalling Windows, but I have a lot of virtual instruments and plug ins installed that I would have to reinstall. I would hate to waste the time if that’s not the problem.


Me neither. I would love one though. :stuck_out_tongue_closed_eyes: :laughing:

Try this

Paste the file path below into the Windows Run command (keystroke Win+R) and navigate to:
%appdata%\Steinberg\Activation Manager

Delete its contents (or move them somewhere safe)

This will initialize the SAM. Then you should try to login anew, and check if that resolved the problem.

1 Like

That fixed it- thanks so much!!!

BTW the shut down and wait 15 seconds was told to me by a Help Desk tech at work a while back. Sounded bogus to me but I do it as a last resort when having problems.

Works for toasters, not for computers.