Suddenly I've lost my UR-22 option in Cubase (SOLVED)

Hello and thank you for reading.

I’ve bought a Steinberg UR-22 because I thought it would be better than using my X-Fi Soundblaster ASIO but now I have no option anymore to choose the UR-22 in Cubase 5. I think I’ve tried everything and mixed all the different settings, deleted the driver and let it rediscover, used USB2.0 and 3.0 ports, different ones, played with the FullDuplex options outside cubase, tried setting it my card in game mode, music mode, turned off creative completely, many other things… I’m very sad at the moment.

I didn’t have much time since I bought and connected all and it worked so I was happy. Now after months of being really busy I finally had a moment of inspiration to try something and I ended up deep in the night stressing how I could fix this.

Hopefully someone can help me!

(using Cubase 5 on Windows 7 64bit, 16GB memory, i5, P8-Z68GEN 3 deluxe, GTX770, UR-22, SB X-Fi Fatality, SSD, HDDs etc)

Is there anyway I can get a new knob for the input gain because this one was so loose it fell off and I can’t find it anywhere, it’s brand new :frowning:

You have certainly tried many things. Forgive me if you have already tried re-installing the UR22 driver/software. Your post doesn’t specifically say that you did. I would try that if you haven’t yet.

I just read it and did that and it helped, I think! Just started up Cubase and it saw the UR22 ASIO. Phew… I only installed it quickly and then didn’t use it for months so I forgot there was even a CD with the device. Thought it was as good as PNP. I also didn’t find a group for it in Programms install/uninstall and the device was fully detected etc.

Anyway, usually those basic steps are the ones I already did but this time I missed it. So thanks for your time and help!!

Glad to help. Have fun!