Suggestions for minimizing spikes and dropouts....

Hi everyone…for some reason i just cant make this i7 4790k, 32gbram, grforce960, audient id22, windows 10 creators fall update pc to work as its supposed to…i keep getting random audio dropouts and spikes all the time on some projects to the point its impossible to mix a basic rock band song. Im looking for any suggestion that can help the system perform better. My cpu is working at 40% when playing back said project and to be able to work ive set my latency to extra safe and buffer to 8192 which are very high numbers…my asio guard is on high. i have checked on task manager and most processes use CPU0 so i have tried disabling it through task manager bun nothing changes really. Other things to consider is that this is a main pc used for more than mixing( i have an i5 that performs better using rme raydat card and some cheap video card instead) also i have various controllers hooked up(console 1, CC1221, Avid Transport and maschine and komplete kontrol s49). Im wondering what could be the cause of the problem…are there too many usb devices connected?is it internet related(of course im not running chrome at the same time and the other pc as i mentioned is on the same network also connected), is it graphics related, or cpu related?Is it just the reality of cubase 9?forgot to mention i use console 1 plugins on all groups (around 16)with about the same amount of slate plugins and around 10 fx channels!..maybe an instance of altiverb and amplitube and a few soundtoys. thats it! i would definately not think its too much!Any help would be appreciated!

I have been experimenting with CPU affinity last night only to find that spikes actually are gone when i use the four out of 8 threads…although this causes other problems like crashes on export etc…anyone has this experience?

You should be able to run with Hyper-threading on but start with turning off all CPU power saving options like Enhanced Intel Speedstep & C States. You can experiment with Turbo mode to see if runs better on or off. In Windows make a power scheme that keeps everything running like your hard disk, monitor and disable all power saving on usb ports etc. Save it and use this as your default Cubase power scheme. As a test you can try the Steinberg Powerscheme but imo it’s not the most optimum because it still turns off hard drives. Turn on multiprocessing in Cubase devices menu. Besides this just experiment with Asio Guard but usually the normal setting will be OK.

Hi again…thanks for getting back…I have disabled speedstep and c states in bios but there is no change to performance…i have noticed that real time peaks occur even if the project is paused and not playing…playing does cause more peaks tho…powerscheme is the steinberg one and multiprocessing is enabled and if i disable it it just goes crazy peaking both cpu and reatime meters. could this be cause by a plugin? All this with the drivers running at 25ms latency!

I’m not at my pc right now so I can’t get specific but, I had similar issues until I deleted the sound driver (and everything else except the graphics driver itself) from the graphics card. Also my mother board came with two sound drivers. I deleted the one named “HD audio driver”. Also, I made sure that all the latest drivers for the motherboard were installed. These things fixed my issues completely.

Also wondering if any of this is related… it does not apply to me so I did not read through it completely enough to know if your cpu applies.

https://www.steinberg.net/forums/viewtopic.php?f=250&t=117319

Regards. :sunglasses:

If it spikes even when noting is playing it’s most probably a driver issue. Like Prock said, update your drivers and see if that helps. If still issues please run this tool http://www.resplendence.com/latencymon without running any other MM applications to see what driver(s) could cause this issue.

Just an update… after i tried everything mentioned and thanks for that i managed to reduce spikes only by a little…i decided to do a clean install of os and everything which is obvliously a pain but it seems not to be much better!ill let you know as soon as i have everything installed

You could also disable the network adapter and see if this helps. It does on a couple of systems that I use.

Mike.

it didnt really help before the reformat…in latency monitor i had another audio driver causing latency…i also have an extra network pci card just for artist transport…

My system spikes with Hyperthreading on, but doesn’t with it off. You didn’t mention that you’d tried this, so just checking… In fact, for me it’s the network drivers which cause the spikes when using hyperthreading.

Mike.

Hyperthreading off just compeletely stops playback…like its way too heavy for the system…seems different for everyone!:slight_smile: