Suggestions/possible bug report

3.5 with a WIDI connected mackie mcu and an ipad pro m1 and whatever usb interfaces i have laying around is great fun.

how about using the ‘signal’ led to show if monitoring is selected for a channel?

also i think the eq mode doesnt work right if you have less than 8 channels in your project.

this is likely to be my daily driver for years to come.

OOPS; moderator: please erase, Didn’t see the activity somehow. I’ll repost.

Yes, the forum’s alive. :grin:

More details, please. You were very specific citing EQ mode.
What’s not working right for you?
And, how did you arrive at 8 channels and not 6 or 9, for example?
I’d like to see if I can duplicate what you’re experiencing and verify that this is a problem for all of us or something unique to your setup.
I like a good challenge. :smile:

lets test the forum here: i’ll split it into two parts. this is trying to use EQ on a regular ole gold standard ‘mackie mcu’, not the pro. straight midi in/out.

if there’s only one track in the session, only the first parameter on the four band parametric eq works.

[“new users can only embed one “… media attachment or whatnot “…. blahblahblah”] per post; error message on forum. pic 2

these no work. the next set of three show that if i have 8 tracks in the session all 8 eq parameters work on any given track.

also, undo/redo at least midi learnable if not in the standard MCU protocol seems necessary to me.

here it is with 8 tracks created. all eq parameters work. if i only have 6 tracks in a session, only the first 6 eq parameters work. follow me? should be an easy one.

cherry MCU with the p&g faders. latest firmware (2.1.2). nice box.

also, there is no way in cubasis to turn off “touching fader selects it” making having select buttons kind of redundant.

again, original “gold standard” mcu at the final firmware “2.1.2”.

oops forgot the one attachment i’m allowed per post

no problem when there are 8 tracks in the session— in this instance, creatively named 1-8. eq works fine on all channels. all 8 parameters.

see how now all the eq knobs work?

this is because all 8 channel strips are flagged as “online” because there are 8 tracks created in cubasis. even though anytime you are in eq mode, even if there is only one track in the project, all 8 top knobs should be activated. it’s a very simple coding bug that someone missed while they were flying through getting the mcu online in cubasis and than likely went back to putting out 100 other fires. nice work


i’ll read the forum rules b4 next take​:sunglasses: serial guys :cowboy_hat_face: :bear::pig:

when i edited the last post it changed my sungless emoji into the word sunglasses but left manbearpig emojis

Who cares about your emojis? That’s a real nice double neck old Fender you have there!
After reading your additional posts and seeing your mixer pics, it sounds like you’re referring to MIDI Learn with your mixer knobs from the parametric EQ in Cubasis? Unfortunately, I don’t have a mixer to test out with MIDI Learn. My Roland MIDI controller (A-49) doesn’t have enough knobs to test this out, either. But MIDI Learn in Cubasis IS the issue you’re having, correct? Just so maybe someone else can chime in or at least Steinberg can explore what you’re reporting.
It is surprising that the # of tracks in Cubasis would have any bearing on the EQ Parameter settings at all.

Cubasis is in “Mackie MCU” mode, so “learn” isn’t an issue. All that is pre-set.

Basically, if there are less than 8 tracks in a session in cubasis, the empty channels on the MCU don’t respond to physical touch of the buttons/fader/knob when in track mode. Neither do they in eq mode (which they should): because all 8 knobs now only work a single channel strip (the active one). A little coding error somewhere in cubasis when activating eq mode on the mcu. sweet that it even works this far! awesome stuff

works pretty great for a first or second release on a little side app; i take it mcu support was only added to cubasis in may 2021 w/ver3.3. i hope they stick with this project, it’s a real winner in my eyes.

thanks btw :slight_smile: It’s not a fender. branded “frontier”. maybe from “matsumoku” factory? i think from 1972 but not really sure, just an educated guess. still tuning it up a bit, just got it a few months back

if anyone has an mcu or an mcu pro or one of the hundred other things that emulate them, try to see how/if eq works I imagine most people aren’t using an -actual- MCU but something that emulates it and might not even have the setting for an eq mode. What MCU controls are actually hard-coded into cubasis match the mackie “nuendo/Cubase” overlay quite well. Someone did a pretty solid job and likely got switched to dealing with something else.

can you map ( “midi learn” ) undo/redo on your controller?

Ah, yes. Mackie MCU in Cubasis Settings. You said Mackie MCU mode but it didn’t register.
I can shed some light on what’s going on. I recently discovered that tracks in Cubasis don’t respond to anything when they’re empty without an event in them. Someone else asked about non-contiguous track selection, and I found that I couldn’t select them—along with other non-contiguous tracks using the Select icon tool—until they have an event in them,
My conclusion: Empty tracks in Cubasis are just visual place holders, nothing more. That would explain why Mackie MCU isn’t working with them, either.
Well, darn, I thought I saw a Fender logo one of those headstocks.

Nope, you’re still missing it. Look at the first picture of the MCU. See how there’s only one track? Its not empty tracks that are the problem, there’s -only one track-. So only that first channel strip on the MCU is active; as it should be.

  1. When I switch into EQ mode, the top 8 pan knobs should now turn into a 4 band eq. 1 frequency, 1 volume, per band.

  2. If I only have 1 track in the session created, when I switch to EQ mode, all top 8 pan knobs should be EQ knobs, but instead only the first one is.

  3. If I have x<8 tracks, even if they are all empty, all x<8 EQ knobs work in EQ mode. ex: If I only have four tracks, EQ mode is only 2 band (the first four pan knobs work as EQ knobs.)

  4. if I have x>=8 tracks, everything works fine. all 8 top pan knobs become eq knobs in eq mode.

The fix likely takes less time than this thread took to write, and probably read, if you have access to the code.

Could someone with an actual mackie running in actual mackie mode confirm? or at least can someone with a device that is not an actual mackie but is running in mackie mode try this (if it emulates eq mode)?

ALSO, IS IT POSSIBLE TO MAP/“MIDI LEARN” the UNDO/REDO BUTTONS? with that one feature cubasis crystalizes into a very elegant and beautiful simplified DAW -perfect- for simple tracking sessions. (ESPECIALLY with USB-C now standard and the plethora of HIGH QUALITY class compliant audio interfaces available)

1 Like

any acknowledgement of this bug?

do i need to ship an mcu to steinburg? :wink:

most of this works quite inspired. good work

this template is what came with mine

last of the normal standard pre-pro i figure