Superior Drummer Muted Cymbal Sound Not Triggering From With

Not sure if anyone else has run into this issue but I’m a bit confused.
I’m using Cubase 8 and Superior Drums 2 and I’m having issues with the muted cymbals. When I play the muted cymbal sample within SD2 it plays fine however if I play the same note through Cubase’s VST drum track section (no midi controller is being used) it only plays the open cymbal and not the muted sample. I don’t have issues with any other drums being mapped (so far). I’ve verified what note is assigned to this muted cymbal through SD2’s Mixer->Mapping section as well and ensured it was correctly labeled within the Drum Map of the VST track. When I click on the Cubase drum track you can see the exact note being triggered in the piano roll in SD2.
Any ideas or similar experiences?

TIA.

Lots of google results on this…not a superior drummer user so couldn’t tell you which has the best answer but the info is definitely out there.

If grims suggestion doesn’t work, maybe you could state the SD pack you are using and the specific midi note for the muted cymbal? That would be easy for me to check.

Also just to clarify, you are addressing what toontrack calls a “muted cymbal” instead of an open cymbal then chocked by a hat?

Thanks for the replies.

What’s this magical Google you speak of? Lol. I’ve searched previously (and then some) and typically try to exhaust all other options before engaging with the help of others but so far no luck.

I’ve narrowed the problem down to Cubase’s Midi Drum Editor. When I play the midi note on the piano roll (no drum map) it plays the muted/choked cymbal sound fine. If I add a drum map (verify the mapping is correct) then it only plays the main cymbal sound. This is the default setup for SD2 and Cubase as I haven’t tweaked any settings (still learning about both their features in these releases).

I’m wondering if I missing some kind of setting on the drum map or something.

Is it a velocity thing?

The piano rolls will trigger the midi sound but if I draw a hit for that particular note into the midi editor it doesn’t play the muted/choked sound. I can create one by adding polypressure but that kind of defeats the purpose of it being mapped in the first place.

I made a quick video of it (linked below). Turn up the volume if you watch it. So far everyone is stumped. I assumed it was user error and I just wasn’t enabling something or doing something correctly but the whole thing just doesn’t make sense.

https://www.youtube.com/watch?v=Kpt9yVP0WRg

And if you make that note max velocity does it mute the cymbal?

Grim,

That’s exactly the issue and has solved it. Clicking on a piano roll or drum editor to hear the various sounds triggers at 100% velocity. When adding a midi note into the editor it defaults to something less.

I was unaware that when using the Mute cymbal articulation, then the velocity of the note determines how long the tail is before the mute. Max velocity = shortest tail.

Thank you to all of you who have assisted me.

Grim,

That’s exactly the issue and has solved it.

I know…The magical world of Google foretold such an outcome :laughing: