Surround Plugins Fail to Load with Montage

I created my first 5.1 surround montage in WaveLab 10 and saved it without any trouble, but when I re-open the montage, all of the MasterSection plugins fail to load, each throwing the following error: “Error reported by L360 5.1 - At this insertion point, the plug-in cannot accept the number of input channels.”

This occurs with third-party plugins and WaveLab’s internal plugins (e.g., StudioEQ).

On successive attempts to load the montage, WaveLab doesn’t display the errors or try to load those plugins again. They appear to be gone forever, along with all of the parameters I spent hours tweaking.

I’ve since discovered that most other 5.1 surround-compatible plugins (e.g., FabFilter Pro-L 2, FabFilter Pro-Q 3) won’t load at all. They throw the same error when you add them to the Effects section of the MasterSection.

Any ideas?

Any assistance is appreciated.

WaveLab version: 10.0.70 (Build 180).
OS: Windows 10 Pro 10.0.19041 Build 19041

The Master Section is not part of the montage. However, optionally, you can save the Master Section preset to the montage.
This being said, try this: load the montage. Start playback. You should see 6 sliders in the Master Section. Now insert your plugins. They will know they must accept 6 channels.
Also, use VST3 plugins, not VST2 plugins.

That’s helpful - thank you. I didn’t realize the Master Section was entirely separated from the montage. Now, the incidences of error messages are a bit more sensible.

I followed your steps and noticed something peculiar. When loading a 5.1 surround montage, six faders appear in the Master Section right away, but when I try to insert the StudioEQ plugin, for example, the aforementioned error is thrown. But, once I play a moment of the audio file contained in the montage, I can then insert that plugin without error.

Other 5.1 surround-compatible plugins will not load into the Master Section at all. They always throw the aforementioned error. All are VST3.

Any other suggestions?

For the record, I discovered the Inspector section and now realize this is where montage-specific plugins belong. So far, all of the plugins I’ve loaded into the Output section of the Inspector work perfectly, including the ones that won’t load into the Master Section.

So, I’m good to go! And I would conclude there’s a bug in WaveLab’s Master Section that prevents certain plugins from loading. I’m guessing it’s isolated to multichannel signals, but haven’t verified it yet.

Thanks again for your assistance.

Well, it worked for a few seconds, anyways.

Returning to my original project, I loaded the montage and put FabFilter Pro-Q 3 in the Output section of the Inspector. “Buzzzz!!!” A horrible noise came from my surround speakers and all of the master level meters clipped. Repeating the exercise with Pro-L 2 did the same thing. Starting and stopping playback produced various buzzes and sometimes produced playback without a buzz, but only in the Lf and Rf speakers. The surrounds show no activity until I remove the plugin from the montage output. Then, proper surround playback is restored.

On further attempts, I noticed the plugins were displaying stereo meters - not surround meters - suggesting that WaveLab is supplying a stereo input. Likewise, when I try multichannel-specific plugins (e.g., Waves L360 5.1) I now get errors: “The following plug-in cannot be connected for processing a stereo input. ‘L360 5.1’”

Any suggestions?

Multichannel plugins should be used in the Master Section only.

:confounded:

So, we’re back to the original problem. Many surround plugins fail to load into WaveLab’s Master Section: “Error reported by L360 5.1 - At this insertion point, the plug-in cannot accept the number of input channels.”

Using VST3 plugins? This message normally appears if a plugin is not capable of handling eg. a 5.1 input.

Yes, all are VST3 and updated to latest versions. In fact, the Waves 360 Surround suite was purchased just last week and the 5.1-compatible FabFilter plugins (Pro-Q 3, Pro-L 2) yesterday.

I will test these plugins in Cubase tomorrow but fully expect they’ll work in my 5.1 projects. In my humble opinion, I suspect WaveLab has a bug in the program logic that communicates with plugins. It’s asking for a stereo handshake when the signal path is, in fact, multichannel. That’s my guess anyways, for what little it’s worth.

Thanks again for helping me troubleshoot this.

So, yes, all of the aforementioned multichannel plugins work flawlessly in Cubase Pro 11. I can only conclude that WaveLab has some multichannel-specific bugs in the Master Section.

Frankly, it makes more sense to insert those plugins into the Output section of the Inspector, where they’ll be stored with the montage for guaranteed recall. If that’s the suggested workflow for stereo projects, then it only makes sense to do this with multichannel projects and plugins too. As is, it feels like a bug or, at a minimum, a design flaw. I’ll submit a feature request.

So, I’ve returned to Cubase for my mastering work until I reach the dithering stage. Then, hopefully, I can bring my tracks back into WaveLab for sequencing, crossfades, dithering, DVD-Audio authoring, etc. It’s not ideal, but at least, I’m making progress.