Suspend VST3 plug-in processing - on or off?

The advice has been, leave this OFF

I’ve been tracking some Arturia software synths and getting some ASIO overloads/spikes - which normally never happens - even on the 32 sample buffer I use. Overall average/maximum load was low, less than 25%. These were just spikes.

Was every 30 seconds or so - and fairly random. Only happened with record monitor ON - was fairly sure it was the Arturia synths (VST3 versions) but couldn’t track it down 100%. Just for fun I switched ON the ‘suspend VST3 processing’. Total ASIO load dropped a few percent but ALL the spikes disappeared. Been running for about an hour without any spikes at all.

Moral is - give that option a try.

Windows 10 - latest versions of plugins etc.

Just looping back on this - I left ‘suspend VST3 processing’ ON for the rest of the session.

Not a single ASIO spike all day - switching it off spikes returned. I’m now ignoring official advice and leaving it switched on permanently. Hopefully this might help somebody :wink:

I’m even going to go as far as marking it ‘solved’ :smiley:

1 Like