Sustain pedal info not following midi

Occasionally…well, a bit MORE than occasionally I take the lazy way out and quantize maybe a bar here and there of my piano part. What’s odd is when just using the straight “Q”, the notes move as they should, but the pedaling doesn’t. Even in old stuff like Opcode Studio Vision (dating myself) this was never a problem. Is there a preference I need to set? BTW, I’m using an NI S88 with a sustain pedal that allows half pedaling, as does the piano software.
I’m running Cubase 9.0.2 (Mac VST).

You aren’t doing anything wrong. In order to Quantize controllers, you have to Select them first (but don’t select notes also).

Thanks, Vic.
Odd that there is no direct link between the midi and controller data such as the sustain. Seems it would be nice if things like expression pedaling and sustain would just travel along. Obviously, one can select the clip “externally” from the main window and move in 1ms increments, but I like working inside.
BTW, wouldn’t quantizing half-pedaling skew the data between the first depression of the pedal and all that’s going on inside?

Yes it certainly would. No easy way around that. Best thing can think of right now (but you’d have to do it individually for each sustain “block”) would be to select a sustain block, then drag it into position, using the “Snap to Events” option, so it would snap to the start of the desired note.

Vic, in the immortal words of “Bones” McCoy…“Dam*it Jim, I’m a songwriter-producer, not a musical technician!!”

Just playing “Devil’s Advocate” for a sec :wink:
Why would you ever want to quantize the sustain pedal? It is far more usual to press the pedal after the note(s) that you wish to sustain anyways :wink:.

Vic, I’m a former concert pianist turned songwriter-producer, but in answer, I’d NEVER QUANTIZE the pedaling. I just want it in the same RELATIONSHIP to my playing as it was before quantizing a few errant entrances. If the pedaling stays put, the next chord is smeared, as the lift is now either earlier or later, depending on where I moved the midi notes.

Ah, I understand better now… it was just that your original post did talk about quantizing the pedal :wink:

One thing you could try (but still note by note, I’m afraid), is to engage “Auto Select Controllers” (once again, not at my music computer right now, but it is one of the buttons in the toolbar of the Key Editor)… you will also probably need to engage, in Preferences>Editing>MIDI>“Select Controllers in note range: Use Extended Note Context”, then drag the individual notes to the appropriate Snap Point, and the accompanying CC# data will follow.

A diifferent approach (but I’ll need to check when i’m back at my machine), would be to convert your pedal data into Note Expression, then I think quantizing the notes would do as you are hoping.

Yes, using Note Expression does work. But please be aware that when using a regular CC (such as CC#64) as Note Expression, it can’t be independent per note (unlike the specific Note Expression-ready parameters in, say, HALion Sonic SE), so, if you have overlapping notes, it is quite possible that the “Pedal Up” may then get attached to the next note, therefore care is still necessary :wink:.