Sustain Pedal Issue in Cubase 9

This could very well be a case of me being ignorant…

But I have been unable to get my sustain pedal to work in Cubase 9.

I am running on Windows 10. My controller is an Akai MPK88 with an M-Gear pedal. I used this setup without issue in Cubase 8.5 and previous versions (and it still works fine if I open Cubase 8.5 rather than Cubase 9).

In Cubase 9, the keyboard plays fine with a VST instrument, but sustain is not working at all. In the transport panel, it is clear that MIDI data is being received by Cubase 9 when I step on and release the pedal, but if I open up the MIDI Monitor plug-in in the MIDI inserts, it clearly is NOT receiving MIDI data.

So why would Cubase 9 be showing received MIDI signals from the sustain pedal in the transport panel, but the MIDI track itself not receive the sustain pedal MIDI signal? And, of course, how can I rectify this?

Hi,

Make sure, the Sustain Pedal (or MIDI CCs in general) is not filtered Out in Preferences > MIDI > MIDI Filter, please.

Thank you for the reply. It’s not filtered out
Screenshot 2017-01-17 15.16.16.png
.

https://www.dropbox.com/s/my6kk8k2muas7od/Screenshot%202017-01-17%2015.16.16.png?dl=0

Hi,

Any MIDI Modifier or MIDI Transformer on the track?

No, nothing. It happens on every MIDI or Instrument track I open up regardless of the VST instrument used.

Do you use any Remote Device? Or is it set up in the Devices > Device Setup? Generic Remote Device, Track- or VST Quick Controls? Isn’t the Sustain Pedal used here?

My pedal is connected to my MPK88 which is set up in Cubase as a Generic Remote. I have tried a couple of xml files for the mapping, including the one that I believe is standard for the Akai MPK series.

In addition to that, the only other Remote Device connected is a Mackie MCU Pro…which is connected using the Mackie Control default mapping in Cubase.

Hi,

Try to set the Generic Remote Device Input to Not Connected, please.

Alright. I tried that, but the problem persists.

I’m pretty sure, it disappears, once you trash Cubase 9 Preferences. But we don’t know the reason then.

What do you mean by “trash Cubase 9 Preferences”?

Hi,

Read this article, please.

Yes, trashing the preferences did resolve the issue.

Thank you for helping me out with that. I appreciate it. Wish I knew which preference was causing the problem…

The MPK example ‘generic remote maps’ offered by AKAI have a big CC Conflict problem!

They assign CC64 to ‘mute’ DAW channels.

Either get rid of those remote mixer maps; or, take care to isolate these maps and your tracks to listen exclusively to different MIDI PORTS (MPK gets A and B ports…16 channels each), or edit them so they’re no longer trying to use CC64 to mute DAW channels!

I’ve no idea why someone had the bright idea to use a CC designated for sustain in a remote map like that :frowning:

Here’s a thread I offered up on the AKAI Forum quite some time ago, along with some sample maps I made for my MPK2 (you’ll either need to change my map to match one of your MPK presets, or change the MPK preset to match the maps).
http://community.akaipro.com/akai_professional/topics/mpk49-mapping-to-cubase-elements-7

You can also find some example maps where instead of setting up the MPC pads to control ‘step input’ in the score editor, I’ve set them up to arm/disarm tracks for recording (Kind of organ stop style):
http://community.akaipro.com/akai_professional/topics/cubase-separate-assignments-for-pads-and-keys

I have been aware of this issue for some time…but that wasn’t what was causing my sustain pedal to not work this time. I tried several MPK mapping xml files and also the MIDI monitor plug-in on my MIDI track wasn’t registering a signal for the sustain pedal which wouldn’t happen if the issue was just that I was using a bad mapping xml.

Trashing Preferences wouldn’t solve this issue. Once you would put the AKAI map back, the issue would be back.

This case was something different.

Hello I’m just curious since you also got a akai mpk88. Have you managed to make all the functions work yet? Because to me akai mpk88 is a total mystery and I wonder if it even is possible to make it work properly.

I’m having this issue right now with my KOMPLETE M32.

The sustain pedal mutes all DAW channels.

Any idea how to change this so that it actually sustains?

Hi,

As far as I know, Mackie Control is using MIDI CC64 as Mute function. Make sure KOMPLETE M32 is not used as Input for Mackie Control Device in the Studio > Studio Setup, please.