Sustain pedal playback not following pedal markings

I use some pedal markings in part of a piano track and up to the end of the first pedal marking the playback is correct. After that point whether or not the sustain pedal will sound pressed or released is completely random and doesn’t have anything to do with what’s in the score. I dug through the forum but none of the solutions to previous problems of similar nature seem to have any effect. Please, did anyone bump into an issue like this?

Edit (more info): if I delete all the pedal markings from the piano track altogether everything goes back to normal and the track is played back without the sustain pedal. As soon as I add one pedal marking it messes up the playback in the measures that aren’t even close to the location of the marking. Really bizzarre.

I can confirm this. I have come across the same anomaly, which is not only bizarre, but also time consuming to fix in the key editor. Very annoying.

1 Like

Presumably, if you needed to adjust the pedal starting and ending points, you did it in Write mode rather than in Engrave mode.

Hello Ata. Which VST are using for the piano? And which expression map? You might see behavior like if you had the wrong pairing, but I don’t want to send you down any rabbit trails.

I’m not familiar with this problem. Can you attach a minimal project that reproduces the problem so I can take a look?

Sorry for my late response, the weekend got me.

Presumably, if you needed to adjust the pedal starting and ending points, you did it in Write mode rather than in Engrave mode.

I didn’t adjust the points of the pedals markings. Besides, inputing or adjusting a pedal marking in one bar shouldn’t influence the behaviour of the playback 10 bars later.

Which VST are using for the piano? And which expression map?

This behaviour is still there while using native plugins and default settings.

Can you attach a minimal project that reproduces the problem so I can take a look?

Certainly! I did a little experimenting and it seems like removing the repeat signs is influencing the behaviour of the sustain playback.

I’m attaching the project, where I removed all the other instruments and left just the piano. The piano track by itself is behaving in the same way as in the original.
Ignis Fatuus v.05 just piano.dorico (797.7 KB)

My observations are that there are three bugs: no sustain where there should be, sustain where there shouldn’t be and ignoring the pedal lifts.

  • B 49, 67 - end of the bar no sustain audible even though the pedal marking is there
  • B 66 - first few notes don’t have sustain
  • B 51-54, 58-63 and 67 - pedal lift ignored, previous chord still audible
  • B 55-56, 64-65, 68-76 - random sustain kicking in where there should be none

Thanks for your help.

I’m sure Daniel will be able to confirm this but for me, remove your repeats and it works perfectly. I tried looking at a MIDI export in Sibelius and it’s clear there that some of the CC64, 127’s don’t have a corresponding CC64,0 and I suspect the repeats are somehow confusing Dorico here.

4 Likes

My current workaround is to suppress playback of the pedal markings. I cannot remove the repeats because ultimately the score is supposed to be played by humans and I need those humans to repeat those bars. :wink:
Although that’s not ideal becasue those jumpy lines that are supposed to be legato are annoying to listen to in playback but oh well…

@call.me.ata
I am not sure about what causes the general issue. But as a memento, you can adjust the timing of the pedal changes in Playback options/Pedal Lines. For the fast 8th notes I found that reducing the Depression length and the Retake length to 1/8 let Dorico catch the first notes of the bars into the pedal, that are otherwise lost in the pedalling due to the fast tempo:

2 Likes

I’ll play around with that tomorrow. I doubt it’s going to fix this particular issue, but let’s see what it does.

indeed – of course I’d never dream of suggesting you actually do that but was only trying to find out what seems to be confusing Dorico to give the team something to consider.

1 Like