Sustain-pedal problem.


I can´t get my sustain pedal to be recorded in Cubase 10 Pro. I got an M-Audio KeyRig 49. I can play with the pedal, but when I record and play back, it only plays the notes as a short note, not “sustained”. When recorded at the end of the track it works, but not when I delete a part in the beginning and re-record. Tried to record at the end and copy it to the beginning but the same issue appears.

Any ideas?



Try this: Preferences > MIDI > MIDI Filter. Make sure Sustain Pedal (MIDI CC 64) is not listed here. Or that the MIDI Controllers (in general) are not enabled (filtered out) here.

You can attach a screenshot to verify it.


Thanks for the reply!

But I see no sutch thing as a “MIDI Filter”. Did not come up in the searchbox either…

Sustain is using a CC which is either on (value 127) or off (value 0). If you record it as midi events (i.e. you open the piano roll and select sustain at the bottom) and you delete the beginning of the part, it might happen, that you remove the control change to 127: the sustain is never activated.
However if you record it as automation, it should work.

Try this: Before deleting the beginning of the part, use the midi function “extract midi data”. It will then be converted to automation and you can see the change on the respective automation lane.
If you record next time, activate the write button (“W” in track header"). CC events will automatically be recorded as automation instead of as part of the midi part.


Please, open Preferences window first. Then follow the path: MIDI > MIDI Filter.


No, Sustain Pedal is continuous in Cubase. Most of the devices is sending just 0 and 127 but some Digital Pianos is using more levels. Therefore in Cubase you can edit the whole range 0-127.

I meant that a sustain pedal usually only sends 0 and 127 (in contrast to an expression pedal). Threshold is at 64 for most vsti. But that’s not my point. My point is that the cc message is deleted when the beginning of the part is deleted

Thanks for the replys, guys!

When I press down the sustain-pedal whilst playing back, it works, and when I release it, it goes back to the short notes.

My MIDI-filter looks like this.


The preferences looks OK. Could you attach another screenshot, please? Key Editor (of the recorded MIDI Part, with the Sustain Pedal) with the Controller lane, where the Sustain is shown. Thanks.

Btw, do you use any Remote Device? Or is any enabled? If yes, make sure, there is no MIDI Input selected on it. At least not MIDI Input M-Audio KeyRig 49.

This is recorded with sustain. When played back, there is no sustain.


When I start recording from like, bar 10 with the sustain pedal, the sustain is working in the playback as well.
Seems like it just does´nt work in the beginning of the recording…

Ok…I can record from bar 2, and it play back with the sustain, but not from bar 1. So it´s not -that- big a deal, but I really want to know what is causing it not to work properly from bar 1…


We can’t see the Sustain in the Controller (bottom) lane. Click to the Volume and switch to Sustain.

But actually it seems to be clear now. You press the Sustain Pedal before the (the real start), therefore it’s not recorded or played back.

In general it’s recommended to start to record at bar 2 or 3 anyway. Exactly because of these possible issues with the record.

Heres a hint, DONT start ANY project at measure 1, always start at measure 2 or later to allow things like sustain pedal to be triggered. You are hitting the pedal BEFORE measure 1, simple

IF you have started something recording at measure 1 and its not playing it, check out Cubase Retrospective Record feature, pretty cool

Hmm…this is maybe the answer Im looking for. Gonna try this out a bit.

Thanks for the tip!

Tried to start the recording for bar 2. But there´s still no “sustain”. But from bar 6 there automatically was…

But as you can see, from bar 5.3, there is two horizontal lines appearing…?


Are these lines Sustain Pedal? Could you open it in the Key Editor and show the Sustain Pedal Controller line?

Didn’t you press Sustain Pedal down before you start the record? The practice is to start recording at bar 1 but start to play a music (record real data) at bar 2. So the 1st bar is some kind of pre-record time (pre-count).

The recording started at bar 1, but I did´nt start to play/record before bar 2. I used the sustain-pedal from the start of bar 2 to the finish.


I would like to see a video with MIDI Monitor, so we could see what does Cubase receive while recording and then what is recorded.

Have you checked the Remote Devices?

  1. Open the controller lane on that track and SEE what your sustain pedal is actually doing. Double click the midi part to open. the editor. Bottom left of that window change VELOCITY to CC64 SUSTAIN. Then take a look at the ON and OFF events for your sustain pedal

OR. open the track control settings/ midi and add Edit In Place, then Apply then you can see the same stuff on the track as when you open the editor when you click the Edit In Place button. Again, change it from Velocity to CC64 to see your sustain pedal data

  1. What sustain pedal are you using?