Sustain Pedal Recording, but not playing back

Hey all, I’m using Cubase elements 11 with a Yamaha PSR EW310. I have a pedal and playback with the keyboard itself is fine. Playback does not have any sustain (which is frustrating as I play very differently without sustain) but it is being recorded. If I record a blank track and just use sustain, the track is not deleted and in the timeline I can see little grey lines denoting the on/off.

Since I’m on Elements, I don’t have the Midi List Editor that people reference so I don’t know for sure which channel the sustain is coming through. If I go through EDIT->PREFERENCES->MIDI->MIDI FILTERS and scroll up in the Controller box, I can find CC 64 Sustain and CC 66 Sostenuto, but I think that might be Cubase saying that’s where it looks for those signals.

Please help me out. This wasn’t an issue with my older keyboard (which had the same pedal by the way), so I imagine it is an issue with the keyboard, but I can’t figure it out or how I might go about fixing it.

In the Key Editor you can change the Lane at the bottom to display Sustain instead of the default Velocity.

@raino Looks like sustain events are being sent to the correct place and are being recorded (picture attached).

So why can’t I hear sustain? Is it perhaps the VST that’s not recognizing it?

Actually you are hearing what your Sustain Data is telling the VSTi to do. Your Sustain is off for most of what’s shown. And when it does go on it is only for a moment and then it immediately turns off again. Working properly it should look more like this.


FYI, if you select one of the data points, the Info Line will will display stuff like its value & MIDI Channel Number. You should look at each of the 6 nodes in more detail to see if there are any clues there.

@raino Interesting. Any idea why it would be doing that?
I’m not allowed to post more than one image because I’m new so I’ll quickly explain the nodes. The left and right clumping (Peak, node directly below the peak, and the other a second later) are identicle:
Peak: Value 127, Channel 1
Node below peak: Value 0, Channel 3
Third node: Value 0, Channel 1

If I raise the channel 3 node, it creates the sustain zone:

It’s hard to know for sure without getting a better look at what’s happening. Unfortunately some of the key tools for doing that, like the MIDI Monitor aren’t available in Elements. But somewhere along the line you are getting Sustain messages sent on 2 different Channels. Does your Keyboard Controller happen to have 2 MIDI Outs on it?

The messages on Channel 1 are the ones you want to use and the messages on Channel 3 are the extraneous messages - which looks to only be Sustain Off messages. In general a VSTi listening to Ch1 shouldn’t be impacted by anything happening on Ch3. But in your case this extra Ch3 data is effecting the VSTi.

The most likely reason is that the Track’s Channel Setting is set to “1” when it should be set to “Any”. When set to “Any” the MIDI data will be sent to the VSTi unaltered. However if you set the Track’s Channel to a specific number like “1” then all the MIDI data will be converted to be on Channel 1 as it gets played.

And yes this is not very intuitive. Up through Cubase 12 the Track’s Channel setting only impacted playback & did not filter by Channel what got recorded - which is why you have the Ch3 data recorded at all. But with Cubase 13 that got changed and it works more like you’d expect.

No, just the one MIDI Outs (if you’re talking about the physical ports that is). Could I filter one of the channels to solve this issue?

EDIT: Just went into MIDI preferences and filtered out Channel 3. Sustain playback works perfectly now.