Svg solution for without metadata?

The svg files exported from Dorico are not accepted and opened in some applications or online graphics sites: The only way I have found for the moment is to open them in “Inkscape” and save them as SVG optimized in removing metadata. But unfortunately in Inkscape there is no batch processing and since I have a lot to process,
it might be good to have the option to export directly from Dorico to an optimized svg without metadata.
I will go and see “github” to find out if a solution exists?
Or do you have another solution?

Can you be a bit more specific about what problem you are having? What application are you trying to open SVGs exported from Dorico in? What specific error message are you encountering?

@dspreadbury Thanks for your answer
My problem is with for example with the fantastic site of design:
They don’t want the svg from dorico
finally I did conversion of the svg with :
GitHub - svg/svgo: ⚙️ Node.js tool for optimizing SVG files
or with gui and standalone app:
SVGO 0.0.9 free download - Software reviews, downloads, news, free trials, freeware and full commercial software - Downloadcrew
best regards

What error are you receiving when you try to take an SVG from Dorico into Canva, specifically?

Here is the error from canva:

Don’t worry and don’t spned time…, in addition to the solutions given above, I found these, after investigations:

  • open the dorico svg file in affinity designer and export it as svg (all options work).
    After comparing the original svg files and processed by affinity, I think I found the problem:
    Dorico exports to svg 1.2 and Affinity to svg 1.1 and obviously only accepts svg1…1
    @dspreadbury Dorico is always ahead and already in the future :wink:

Another constat if ever for those who like me do a lot of didactic sheets and have to rework the dorico exports and want to stay in svg:. Be careful if you edit the Dorico svg file in affinity designer by adding layers, do not put any empty spaces in the names of the layers otherwise your new svg file after exporting will give the same error message in “”: therefore replace the empty spaces in the names with an underscore.
Best regards