Swapping voices

See screenshot:

Screen Shot 2022-09-19 at 10.25.51 PM

For some reason, the top voice has stems going down. I tried selecting this measure and going to Edit > Notations > Voices > Swap Voice Contents, but it doesn’t flip the top voice up. So I must be missing something. What am I missing? How can I identify which note is in which voice, then get those descending quarter notes to be stems up?

Update: I’ve now found that in previous sections of my score, Dorico has now gone and changed the direction of stems throughout. Like this:

And I can’t seem to be able to figure out how to intelligently have the top voice stems going up, and the bottom voice stems going down. Probably the same issue, but I don’t know what the fix is.

Are you using Up-stem Voice 1 and Down-stem Voice 1 or something else?

Have you tried selecting all the errant notes then pressing F to flip them?

First thing is to turn on Voice Colors, under View > Note and Rest Colors > Voice Colors. That will show you much more easily what’s going on.

You can also select a single note, and the status bar in the bottom of the window will tell you which voice it’s in.

Once you know which notes are what, then you can set about putting them in the right stem voices, and resetting any manual flipping.

While composing a piece a few months ago, I had the same issue. Suddenly, stems in different voices were flipped the wrong way. I tried swapping the voices too. After getting frustrated, I closed Dorico and came back the next day to compose again. To my surprise, closing Dorico and restarting my computer fixed the stem issue. Bug, maybe?

Dorico will clean up any unused voices when loading a saved project, but this should never have any effect on what you see in your score, because by definition those voices were unused. If you have a reproducible case of this (i.e. an edit you can make while working on your project that then causes the disposition of stem directions etc. to change when you reopen the project) please provide it.