Switching sampling freq. with MME-WDM driver

I have an issue with sampling frequency switching on recording in recent version of Wavelab (7 - 8.5)

Setup :

  • Using MME-WDM drivers (not Asio) with a UH-7000 tascam interface in windows xp
  • In the Record Box :
    Let us suppose that the interface is presently set to 44,1kHz sampling freq.
    In wavelab 5 (for test purposes), if I select (in temporary file mode) a 48kHz format, the monitor box unchecks itself automatically. If I then recheck the box, I see that a command has been sent to the interface because it is now set to 48kHz.
    In Wavelab 7 - 8.5, if I do the same operation, nothing happens on the interface
    How come ? Has something changed in the way Wavelab “talks” with the interfaces since Wavelab7 ?

I need an answer to this first, because it is at the root of many problems I have been having with my faithfull RME DIGI96/8 Pad pci card since working with wavelab 7.
I don’t want to go into the details until another post since I haven’t finished investigating the details
I want to stress that it is vital for me to be able to record and read 44.1, 48k files at any moment without having to fiddle with the soundcard settings like clock source. Until version 6 everything worked like a charm. My soundcard is in “master” but when recording the soundcard sync to its EBU input as long I as I choose the right sample frequency setting in the record screen. Asio driver is absolute hell for me since it locks input and output together for sampling freq.

Mark Haliday

if your sound card is the master of the sample rate, wavelab cant change the sample rate, by definition. it was no different in walelab 6.
when recording, wavelab does not do any resampling, and the audio card sample rate is set to the sample rate of the file format you select in the record dialog.