SX3 > Cubase 6 - FX and VST Seem Incompatible...

I began with SX1, went to SX3 and just upgraded to Cubase 6 (C6) - now on my 64-bit system (all previous were on 32-bit XP). The attached screenshot shows a couple of really basic FX that C6 are not compatible - old Reverb 1 and the Q - that I used a lot. The only thing I see possible is to have to start all over from scratch with the new Reverernce, etc. Not fun considering I have a lot of tracks.

I also have old VST freebies that worked just fine such as Classic EQ that now aren’t recognized. I thought C6 is supposed to be backward compatible – seemed they touted it as one of its qualities.

Whatever the case, is there a way for one to force C6 to:

1. Use settings from older Steinberg FX such as Reverb, etc. “translated” into/as the new ones?
2. Recognize older VST plugins?

If so, how/where?

Thanks.
CS6 FX.jpg

Did you point to the location of the plug’s .dll’s via Plugin Info- VST2.x Paths and re-start Cubase?

Yes, I did (“VST Plugins” folder). Before I did that, there was a whole list of things stated as missing; once copied the contents of my old SX3 VSTs into C6’s, I only got the errors shown in the previous screenshot.

One reason I had to get C6 – well, two reasons – is that I went to 64-bit and SX3 was getting sluggish or something for I have a lot of tracks (Pink Floyd-ian/orchestral layers); then when I tried to re-install SX3 after I tried C6 Trial, the new eLicense and old one bundled with SX3 (the logo for eLicense is older version) seem to clash and I get the error in screenshot below (even when I try Windows 7 in Safe Mode). Yet the dongle says I’ve got SX3 license.

I wish I could re-install SX3 so I can visually duplicate some of the reverb/Q and other settings visually. I could and may decide to also install C6 32-bit, but that wouldn’t change the plugin/FX problem.
SX3 eLicense conflict.jpg

Tried a rescan in plugin information window?

Don’t actually run too much of old plugins, but Q for example is working in C6.

Did as you said, but as you can see from from the first screen-shos, the Q and Reverb A plugins in the project (and in others) that are missing are older Steinberg ones that it finds but calls “MissingFX”. When I hit “Update” the VST Bridge that does the update freezes Cubase and I have to close the project.
C6 MISSING CSX-3 NATIVE PLUGINS.jpg
This second on is the pop-up when opening the project reflecting the above.
Missing Plugins on Project Open.jpg

Try copying the dlls into the VST folder. The plugin information window shows C:\Program Files\Steinberg\Cubase 6 as path, I think those old plugins don’t feel well there :smiley:

No at C6 right now but will experiment with putting dll in some file where they will be recognized – I did think the parent directory seems strange…

ANOTHER Question on workspace:

In SX1 and 3, it was so handy to right-click on an audio file or other file in the track and have a substantial drop down menu to do stuff, i.e. Audio, etc. No such thing now – have to go to the top window menus and choose – time consuming, feels like hunt-and-peck. Or am I missing a setting somewhere to have this function available?

Thanks.

If you are having licence problems then you should check you have the latest eLicence drivers… Also, this may be an issue for official Steinberg support.

On the subject of FX, you could also try JBridge. This is by all accounts a more reliable alternative to Steinberg’s own bridge software. It’s only a few quid and many people have found it sorts them out.

Finally, yes, I really wish Steinberg would re-implement and include their original plugins. I use Mod-Delay like there’s no tomorrow, and I simply haven’t been able to get the same out of their latest batch of delays. One might even go to say that the old plugins are becoming retro, time they were re-issued!!

Mike.

I use C6 32-bit and have access to all the old plugins - so you could try to install that.

There’s a setting in the Preferences somewhere.

Thanks. I’ll look for that in Preferences though… I just now discovered that if I right click with CTRL, the drop-down shows up. Hallefreakin’alullia - lol.

Do you see a toolbox instead? If so, then there’s a preference to switch back to the menu style, but I can’t remember what it’s called…

Mike.