Synchronize Cubase & Logic on Mac?

Is it possible to run Cubase & Logic together In sync on Mac while one is a master and the other is slave?
And if the answer is yes, how yo do it?

Unfortunately, neither Cubase nor Logic doesn’t have ReWire slave mode. They re both ReWire master only. If you will use two machines, you can do this.

(I don’t have Logic myself, but , I presume it can slave to MTC (MIDI Time Code)?..
So long as, in the Mac’s Audio MIDI setup, you have enabled the IAC Bus, you can set up Cubase to transmit MTC from IAC Bus, and receive it in Logic on the corresponding IAC Bus (or vice versa :wink: ). (I’ve just tried it between Cubase 6 and Cubase 5 here, and it does work.)
N.B.1: Of course that means you have to set up your Project start times accordingly.
N.B.2: While this does indeed “clock” the two DAWS synchronously, in fact the two remain tempo independent (e.g. you could set up a different tempo in Logic). In practice, with the two DAWs running at the same tempo, they should remain perfectly in sync long enough to do even the longest projects, without drifting (especially seeing as the both DAWs are on the same computer).
You might, additionally, wish to add MMC into the equation (for easier Transport control) :wink:.

Give me a little time and Ill do it for you since I have both DAWS here

Thanks very much Vic but although I enabled the IAC I don’t see it at both Logic and Cubase.

And Shanabit, I will appreciate it very much if you’ll do so :slight_smile:

Slave Logic to Cubase Settings

  1. Go to AMS and click on the IAC driver and check the box to set it to Device is Online, apply then done

  2. Cubase:
    Project Synchronization Setup
    timecode source=Internal
    MTC Destination box = IAC Buss

  3. Logic:
    Settings/Sync/General
    Sync mode=MTC

Bar position 1111 plays @, set the SMPTE to look like 00:00:00:00:00

Great!! it really works! Thanks very much shanabit.

Nice! Thank you.

I didn’t know if you wanted Cubase or Logic as the Master? I’m trying to get Logic to control Cubase now, having some issues but Ill keep hacking at it. Glad it helped so far

Funny when I have Cubase control Logic the SMPTE and Bars/Beats lines up. When I have Cubase slaving its WAY off
Still looking


Yall is welcome, anytime

shanabit, could you please explain the above line. I have done your first instructions successfully. When I press play in Cubase, it triggers the metronome in Logic at the correct speed, however the “cursor” disappears from Logic so it doesn’t play anything and I can’t get the Bar+Beat position to line up.

What’s my missing step?

Sorry, figured it out. The Sync Mode window has option to align SMPTE.

All working now, except for some reason some of my MIDI in Logic is getting transposed for reasons I cannot fathom…

Heya,
New to Cubase Artist 8.5…I’m missing the steps on how to line up the Metronomes? I get sound from Logic but it’s not perfectly synced to Cubase.
Thanks!

In Logics synchronization setup window. File/Project Settings/Sync, Open the Sync/General tab. Where it says
Bar postion 1111 Plays at SMPTE, adjust the box on the right in the secs column. Hours:Min:Sec:Frames:Bits

**Make sure you have Cubase and Logic set to the SAME audio buffer size. I set both to 64 samples here then adjusted that window in the secs column until Logic matched the click of Cubase, I increased it to 5 in that column

This is Cubase controlling Logic BTW

shanabit, these instructions are perfect! I got it working first time. These instructions were intended for when Cubase and Logic are both on the same computer yes?

How would you do the exact same thing except you are slaving Logic X to Cubase 9, and both sequencers are on different computers connected via ethernet? I’ve tried many times to duplicate this synchronization on two computers without luck. Any help would be greatly appreciated!

I’ve been able to slave Logic to Logic on two different computers on a network, but no luck with Logic to Cubase.

  1. Yes, same computer both apps synced and running

  2. Two diff computers, try this http://www.nerds.de/en/ipmidi.html

Wow! I owe you big time Shanabit. This worked first try as well. I cannot thank you enough :slight_smile:

Welcome bro

I tried this but I’m not seeing anything happen? My playhead in Logic turns blue, and sometimes the playhead starts before bar 0 if I move the playhead in Cubase further out, but both DAWs are still very independent and there’s no syncing going on. What should be happening?

Same here, logic just goes to - 8bar

I mean negative 8 bar. -8