could not be started

I see many threads on the forum concerning an inability to start Dorico because of trouble with Synsopos that has yet to be fixed by the developers. I have a different problem, one that apparently is not addressed anywhere I can find it. I am trying to install Dorico on a brand new MacBook Pro, and in order to do that I first have to install the eLicenser Control Center. The install goes without a hitch, but when I boot eLicenser Control Center, I am met with the following message:

eLicenser Control Center then crashes as soon as I try to do anything with it. Restarting or uninstalling eLCC and re-installing it have no effect. Apparently everyone else’s problem with Synsopos is that their version of eLCC is newer/older or something than their version of Synsopos—but this is clearly not my problem, because the computer is brand new and everything on it was downloaded straight from the internet today. Any idea as to what’s going on here, or how to fix it?

Does this thread help, Cor anglais 16?

Cor anglais 16,
I am not 100% sure but, start by downloading the Steinberg Installer, then choose Dorico from there and download it. The eLicenser will be automatically installed as part of the Dorico download.

Open a terminal and navigate to /Library/Application Support/Synchrosoft/pos/
That is the app that the eLicenser Control Center tries to launch.
Is it there and what permissions does it have, does any user have execution rights?
Can you launch the app from there?
Since it is a background app, it won’t show any window or menu, but in the Activity Monitor a process with the name Synsopos shall appear.

It’s there: not in my user Library, but rather in the System Library. Permissions are rwxr-xr-x. I can launch it from there, and it shows up in the Activity Monitor (but it was already showing up in the Activity Monitor before, when the message would pop up).

Sorry, I had seen that one already; no help there. It’s one of several that claimed the versions were mismatched.

Thanks, giving that a try now. So far it’s downloading things, which is further than I got with trying to run eLCC…

No dice. Everything’s downloaded and installed, but now I’m at the point where Dorico won’t start, and eLCC won’t start either because of this Synsopos thing not being able to be started (even though it’s running in Activity Monitor).

Kill Synsopos in the Acitivy Monitor and then run the eLCC, does it then launch?

No. Killed Synsopos, ran eLCC, same message. Synsopos just re-appears in Activity Monitor. Clearly Synsopos is starting up, even though the message claims it’s not…

Can you grab a screenshot of the About eLicenser Control Center window and attach that here?

Sure, try this:

Update: I tried from a new administrator account and was able to start up Dorico, and tried to put in my activation license but it was denied because it’s a Dorico 1 trial license and I need a Dorico 2 trial license (long story)—but that’s a different topic that I’ll investigate myself. Looks like I’ll have to migrate everything from one account to the other, and ideally rename it. Does anyone know if Dorico/eLCC will flip out if I rename the home folder?

Off-topic, but be careful renaming your home folder, you could get locked out.
Make sure to follow the steps listed here:

I don’t know whether or not your Soft-eLicenser will go bananas if you rename your home folder. The Soft-eLicenser file itself lives in the system-level Library folder rather than the user-level one, so I hope it would be OK, but I’m afraid I don’t know.

Before you do anything drastic, make sure you have registered your current Soft-eLicenser and all of the licenses it currently has on it at MySteinberg, so that you can use the big red ‘Reactivate’ button there to get new activation codes if all else fails.

Thanks for the warning, Daniel. I took the appropriate precautions, and then the plunge, following the steps Thijs Boheme provided above. For future reference, this is what happened:

  • Dropbox wouldn’t start because of a permissions error wrt ~/.dropbox. I used sudo rm -Rd ~/.dropbox to remove that directory and all was well.

  • Dorico hung on start. I solved this by starting eLicenser Control Center prior to starting Dorico (and ran the maintenance tasks for good measure), as referenced in other threads. Then Dorico started just fine. Since then I have not had to have eLCC open in order to run Dorico.

Everything else was nondescript. All appears to be well at this point. Thanks, all, for your assistance!

Quick update: every time I reboot the computer, it looks like I have to have eLCC open just the first time I boot Dorico. Life could be worse…

You could add it to your startup list :wink:

Cor anglais 16, it would be helpful if you could email me an Apple System Report. Choose About this Mac from the Apple menu, then click System Report, then choose File > Save, and attach the resulting .spx file to an email to d dot spreadbury at steinberg dot de.