System text moves grace note

I added a system text to a new line and started to input a grace note. Dorico immediately put the grace note before the eighth quaver – I obviously wanted it to be before the first.
Has this something to do with the system text being in the way? EDIT 2/6/18: Yes, it has. It shouldn’t happen though…
How do I move the latter (alt-arrow doesn’t work)? I’d like it to be further left.

Bildschirmfoto 2018-06-01 um 19.53.35.png

No answer, really?

All I can suggest is that you didn’t have the first rest selected when you tried to click in the grace note. See video:

Oh, and you can move the grace note by selecting and using Alt+arrows (left or right) - it should move by whatever your rhythmic grid unit is (eighths/quavers in my case)

Strange – after watching your video I created a new project and couldn’t reproduce the behavior. The behavior is like in your video.
I did exactly the same thing yesterday: selecting the rest, inputting system text, escape, double-click on the rest for note input, enter first grace note in the beginning and – whoops – it got moved to the position shown the attached screenshot in my post above.

Moving: Is there a way you can move system text?

Yes. Like most other things it’s linked to a rhythmical location. You can adjust that using alt+arrow keys, in Write mode, or you can go into Engrave mode and either drag it around with a mouse or use alt+arrow keys (or Cmd+Alt+arrow keys for bigger increments).

Ooooh! Ok. My mistake. Frames were still enabled, so I couldn’t select the text, I kept selecting and deselecting the frame.
Still, I’m very sure that yesterday I couldn’t move the text at all, neither in engrave mode (well, it’s clear why) nor in write mode.
Everything’s fine now, although selecting and moving things around feels “reluctant” at first. Like a donkey that needs a convincing nudge…

Thank you for your time and help, Leo!