Take lane handling/numbering bug in Cubase 12.0.20

In recording multiple passes of multiple looped takes for an audio track today, I encountered what appears to be a new bug in take lane numbering and handling. The good news is that no takes were lost, though that was not immediately apparent. This issue will only likely be seen when recording two or more passes of multiple takes (with looping enabled). Here is what I did and what I observed (including screen shots):

  1. With looping enabled, recorded three takes. These results were as expected – i.e. takes 1-3 in lanes 1-3 for the audio track, with take 3 left as the one that would play. For reference, my general record options settings are:

Cubase 12.0.20 recording options

and my audio recording options are:

Cubase 12.0.20 audio reording options

  1. After saving the project from the first set of takes, started recording another pass of takes (again with the intention of doing three takes in a row). However, while I was doing the second take, I glanced over at the screen and noticed that there was now a blank lane in what would have been the fourth take (i.e. the first one I’d done in the second pass), but I was seeing the take I was recording at the time (take #5) appearing in Lane 5. (Commence freaking out as take #4 had seemed like an especially good one.) Once I finished take #5, I did not take a screen shot at that point, but my recollection is that it appeared that one take (assumedly take #4) was missing.

  2. Did a clean up lanes operation, hoping the missing take would come back. Here is what I saw (annotated):

Specifically, take #4 was in lane #1, with takes 1-3 shifted down to lanes 2-4, a blank lane 5, then take 5 in Lane 6. I tried clean up lanes a few additional times, but the result was still the same.

  1. Recorded another pass of multiple takes, this time only two (intentionally as I was mainly wanting to the one I didn’t do on the previous pass but also wanting to see if the weirdness happened again). Here is what I saw (annotated) immediately after recording:

These should have been takes 6 and 7, but they were actually numbered 7 and 8, and take 4 (from the previous round of takes) appeared to be missing, with take 7 up in lane 1 where take 4 had previously appeared. And there were blank lanes in lanes 5 and 7. After a cleanup lanes operation, the screen looked as follows:

That is, Take 7 and Take 4 were now in lanes 1-2, respectively, with takes 1-3 shifted down to lanes 3-5, a blank lane 6, take 5 in lane 7, a blank lane 8, and take 8 in lane 9. Also, there was a new lane 10, which did not exist prior to the cleanup.

  1. Recorded one more pass of of 3 takes. After recording, the screen looked as follows:

So, again, the last take from the previous pass (which should have been numbered 6, but was numbered 7) appears to be missing, while the first take from this new pass is in lane 1, with various other shifts and empty lanes. After cleanup, this changes to:

So the pattern remains similar, with the initial takes from each pass being up at the top, but bumped down one each pass, with various empty lanes and shifts. At least there is no actual missing data.

  1. Because the ordering of the takes is actually significant (it has to do with warming up on the first batch of 3, usually getting the best takes in the next batch of 3, albeit this time 2 batches of 2, and doing a bit more experimentation in the final batch of 3), I manually moved the takes around to get them in sequential order, then did a cleanup lanes operation, hoping to remove the holes and get the lanes and takes in sequential order (despite the numbering being off). However, this is the result:

That is, it left Lane 1 empty, but did at least keep the sequencing of the rest of the lanes in numerical order. (After that, I manually moved all the takes up to lane 1 and did another cleanup lanes, and it did clean up the one remaining extra lane without introducing any new holes.

Again, the good news is that no data was being lost, though that appeared to be the case visually ahead of doing the cleanup lanes operation.

I think I have also seen this happening on MIDI recording (in which case I may have also seen it in 12.0.10), but I don’t tend to do the batches with MIDI recording, and I just vaguely recall seeing something weird like this one time, without paying much attention since cleaning up the lanes at least got the takes back. (And there are other aspects of MIDI recording that work differently when doing batches, so I may have just thought I made a mistake the time I did see something weird.)

I should probably note that I am on Windows 10 in case the issue might be platform specific.

I’ve seen this behavior for several years and several cubase versions. Either no one complains about it or Steinberg doesn’t think its a serious issue. But whenever they changed how lanes functioned (which was a good upgrade) the consecutive placement or numerical placement of multiple takes became inconsistent. So like you see, if i do multiple over dubs on different dates they do not stack consecutively. and if I arrange them myself to have the latest take on top of the lane view it doesnt matter. the next time i do overdubs the new takes will fall out of order. Cleaning up lanes will not resequence the takes or correct the sequence. Luckily the event names are still consecutive. I do not need the event numerals to match the lane numerals but it would be nice if the first take was at the bottom and the last take was at the top of the lane – or the opposite if thats how your brain works. But the random order is annoying .

What’s weird is I did another project after reporting the issue above, where I did the same sort of tracking process (it is my norm for tracking lead vocals as I do several takes, have a break to get a drink of water and rest a bit, then do several more takes, then repeat once more), but I did not have the issue. I think it may have been with 12.0.30 that time instead of 12.0.20, but there was nothing in the release notes for 12.0.30 that suggested this issue was addressed. What was particularly scary about it when I encountered it initially, though, was that the takes initially appeared to be missing (until after the clean up lanes, which then showed the weird lane arrangement), so I’d initially thought it was losing data. I’m pretty sure the one time I experienced (and reported) this with 12.0.20 was the only time I’d seen it, at least in this specific context (I might actually have seen it once or twice with MIDI tracks in Cubase 12, but this sort of process is something I don’t use as much for MIDI tracks as I don’t need to get a drink of water or rest between takes), and I’ve used every version of Cubase Pro since 9.5. I generally only use this process on lead vocals, though, not even background vocals (where I tend to do a section at a time instead of singing the whole song straight through), and I’m not super prolific due to being somewhat slow on the production process, so it’s not like I’m doing this specific task every day or even every week.