Tascam US-2400

Hi, I wonder if I could ask for some help with a topic that’s only tangentially Cubase related.

I’ve recently joined the small but dedicated band of Tascam US-2400 owners, and with a good deal of help from posts in this forum, I’ve got it set up and working with Win 10 and Cubase 10.5. It’s a superb controller, very professional feeling and a pleasure to use. It’s a real shame that the market doesn’t seem to be able to support controllers like this.

I have a problem with the Jog Wheel and Joystick, though. When I first plugged the US-2400 in, the Jog Wheel was behaving correctly in Cubase. Smoothly fast-forwarding and rewinding and scrubbing nicely when the Scrub button was pressed. Following advice from these forums, I updated the firmware and switched the three Mackie Control instances to Compatibility Mode. This had the effect of properly enabling all the functions (Aux Send and EQ etc) on the US-2400 in Cubase mode.

Unfortunately, when I tried the Jog Wheel again, after these adjustments, it had stopped working completely. After some investigation, I’ve ascertained that the Jog Wheel is now transmitting on Port 4. This port, as I understand it, should be reserved for the Joystick. I believe the Jog Wheel should be on Port 1. The result is that Jog Wheel and Joystick both now do very little, other than send very erratic data on Port 4. They appear to be conflicting with each other.

I wonder if there are any other US-2400 owners out there who could shed any light on this.

In case anyone is interested, this issue is now solved. The controller was faulty. I now have another US-2400 and the jog wheel and joystick are working perfectly.

My advice, if you buy one of these brilliant controllers - or any older gear - is to check that the PSU that comes with it is the correct spec before plugging in. Lesson learned there, for me.