Tempo bug in condensed score.

Why do the tempos suddenly start appearing on all the staves in mid-system here? Notice that the rit at the start of the system appears only on the flute staff and the violin staff. But then from poco accel. on, tempi appear on all the staves. In the uncondensed score they act normally.

???

Hi Alan!
I don’t have that behavior at all, so something else has to be causing this. I don’t think that picture will really help diagnose what the problem is…

I just tried closing the file and re-opening it, and now it’s OK. So I unfortunately can’t reproduce it. :frowning:

If it happens again, please post a cut-down version of the Dorico project, not a picture, as per the guidelines here.

OK, now it’s appearing and disappearing unpredictably. Try opening this file and going to m. 281 in condensed view.
Tempobug.7z (1.11 MB)

Same file: notation options (make no changes) -> condensing -> Save as default, then close -> Dorico crashes completely.

I can’t replicate that crash here, Alan…

I just tried in another file, and had the same crash after save as default in notation options->condensing. I don’t know what to say. :frowning:

Where do I send the diagnostic report, it’s too big for here?

Either stick it on Dropbox (or similar) and share the link here, or email it to d dot spreadbury at steinberg dot de with a link back to this thread (so he knows what he’s looking for).

Done. Sent to Daniel.

The crash is caused by being able to close the Layout Options dialog before the ‘Save as Default’ operation has completed, which then results in Dorico crashing when it tries to update the state of the dialog once the operation has been completed. We’ll make sure this can’t happen in future, i.e. by preventing you from closing the dialog while an operation like this is in progress.

Great! :slight_smile: