Tempo Detection Messes Up MIDI Timing

I had a project with some MIDI tracks which were divided up into Events. Those Events lined up perfectly with bar boundaries.

I imported an audio file that I wanted to play along with the MIDI. I selected the audio event that resulted from the import, executed ProjectTempo Detection, and hit Analyze.

As a side-effect of doing this, the MIDI Events were moved so that they no longer fell on bar boundaries. Not only were the Events moved, but their lengths were changed as well, e.g from to

I do not understand this.

Why did Cubase do this to my MIDI tracks? Is there something I could do to prevent Cubase from doing this?

Cubase 11.0.20
Windows 10, fully updated
Surface Tablet i5


I’m assuming when you refer to “MIDI Events” (a MIDI Note, or a CC Data Point) you really mean “MIDI Parts” (the entities you edit in the Key Editor). If this is incorrect please point it out.

Can you post a screenshot of the Track with the unaligned MIDI Parts making sure to include the Inspector.

You are correct, I meant MIDI Parts. The wording in the Cubase 11 Operations Manual on page 202 had me confused about that.

Here is my project window before I did the Tempo Detection:

You can see that the Parts in the MIDI tracks line up with the bars.

Here is my project window after I did the Tempo Detection:

The Parts in the MIDI tracks no longer line up with the bars.

Here’s a good video from resident Cubase Guru, Greg Ondo, showing how to use tempo detection.

I think you may need to change your track settings from time based to tempo based. The toggle icon is in the track inspector and is a clock when time based and a note when tempo based. Yours shows that it has switched to time based (clock) after the detection for the bass track that is highlighted and showing in the Inspector.

Cool video, but it doesn’t address my question/problem, which is the alterations to my MIDI tracks.

Did you see the lower half of my post about setting your track back to tempo based?

1 Like

I did see that. I figured it would not help because I wanted the MIDI Parts to stay aligned with the bars, which is “musical,” not “time-based.”

But I figured it would be worth a try to see what would happen, so I just did that. The result was the same: the MIDI Parts became misaligned with respect to the bars when I did a Tempo Detection.

Here’s the Cubase project, in case anyone’s interested in examining it.

zip file

In the one where the MIDI is messed up you have it set to Linear Timebase, you need to keep it set to Musical Timebase.

That’s the way it was set previously. Or am I misunderstanding?

It actually is set different in the before & after pics you posted. I have no idea what you are referring to by “set previously” - but that doesn’t really matter. Just leave it set on Musical Timebase all the time - that tells Cubase to anchor Parts & Events to a Timeline measured in Bars & Beats. When it gets set to Linear Timebase then Parts & Events are anchored to a Timeline measured in Minutes & Seconds.

At a static Tempo, for example Bar 4 might start at 12.7sec but if the Tempo was increased then Bar 4 might now start 11.2sec. When you make Tempo changes Tracks set to Linear Timebase will maintain their absolute position relative to mm:ss but will also loose their previous relationship to Bars & Beats.

The first image in the third message in this thread clearly shows that the MIDI track is set to musical time base. This phenomenon of the moving MIDI Parts definitely happens when the MIDI track is set to musical time base.

Further down in the thread, I verified that the phenomenon also happens when the MIDI track is set to linear time base.

I just noticed that after the tempo detection, the MIDI track setting gets changed to linear time base. But changing it back to musical time base does not cause the MIDI Parts to line up with the bars.

I just came across this as well - I am pretty sure it worked correctly in the past.
mtrigoff is quite correct - I f the MIDI tracks are set to musical time base, they are changed to Linear Time Base as soon as you do the Tempo Detection. The result is that all MIDI data ends up in the wrong place.

1 Like

Just ran into this. I have three instrument tracks, all set to musical. I tempo detect an audio track. Afterward, the instrument tracks are set to linear time and do not match the new tempo track.

Any solutions on offer now?

The way I do it - Before doing the tempo detection export the midi data as a midi file.
Then delete the mid tracks.
Then do the tempo detection and import the midi file that you exported earlier.
The new midi now conforms to the new tempo track!

1 Like

Cubase 12 here. I’m trying to get my head around this myself as I am currently importing 16 channel drum multitracks into an existing fixed tempo track with a varirety of audio and midi channels.
It would appear running tempo detection (on the kick drum channel in my case) resets all midi channels in a project to linear…but it would appear not to do this if you lock them first before running the tempo detection… if that is a clue that helps for anyone.
Then again I don’t know if this helps anyhow, as you need to lock them anyway as a process (and I can’t see a bulk way to do multiple tracks…maybe a macro might do it?) and this “timebase convert” to each midi channel seems to happen each time you do a tempo detect action…so your clicking them back to musical manually anyway after running it. Still…locking a channel does seem to keep it from converting midi to linear from what I can see. cheers

Check out this video where Dom shows how to do this manually (not all that much work) to get around the limitations you might run into using Tempo Detection

1 Like