Tempo Marking Disappears in Page View

I’m finishing up a score for submission and I have a weird problem: on page 1, where the two vocal staves are hidden, I am trying to insert a “poco rit.” marking. It will show up in Galley View, but not in Page View in either Write or Engrave. Any ideas? I’ve tried deleting and re-creating, same problem.

Can you attach the project here, or send it to me by email?

Song of Thanksgiving (ANNA CECILIA) (Ward).dorico.zip (201 KB)
Done. Thank you, Daniel!

I faked it with a text object to move the project along.

This is in bar 8, is it? It seems to work OK for me – do you see “poco rit.” in the attached project?
Song of Thanksgiving (ANNA CECILIA) (Ward).dorico.zip (109 KB)

I do. So weird. Could not get that mark to display for anything. Thank you? =)

Just in: happened again tonight with a different file.

Very odd. Can you send me that file, too, and tell me where it’s happening?

Will do, but I’d like to email it this time. (address?) In the meantime, I tried to create the bug in a new file and couldn’t (see attached).
Tempo Markings Bug à 3 Full score 1.png

My email address is d dot spreadbury at steinberg dot de.

Bumping this as I think I can recreate this problem (or at least a similar one) in Dorico 1.1.

What’s shown in the gif is two systems, where in the first system the vocal line is empty and thus hidden.
The accel. shows fine in page view as long as the attachment line only runs to the end of the system. If it runs on to the new system the whole object disappears.

This behaviour doesn’t seem to happen unless there are hidden staves involved.

Anybody got a workaround?

What happens if you extend the accel. line in Galley view and then go back to Page view?

If you slowly move the mouse further down towards and over the piano staves, does the line reappear?

I’m away from my desk just now, but I believe it’ll show in galley view but not in page view. Will happily confirm with a gif in the morning.

Gif to show that no, if I move the mouse down and over the piano staves the line doesn’t reappear. Though the act of selecting galley view is off shot, the end of the clip is galley view after the object has disappeared in page view. The object’s still there, it’s just not showing on the page.

Derrek, if I extend the accel. line in galley view the line doesn’t show in page view. If I reduce the line to only cover up to the end of bar 53 the line reappears in page view. If I force measure 54 onto the previous system the line reappears.

edit: the file in question has previously been tweaked by Daniel to do something completely unrelated. Just to ensure it’s not an isolated case I started a new project - see attachment. There’s an accel. in bar 3 to halfway through bar 5. It only shows in Galley view, and it plays.
Hidden Accel.dorico.zip (598 KB)

The problem appears to be that when you have a gradual tempo change, a score in which empty staves are hidden, and you try to drag the end of a tempo line from one system to the next, the tempo line won’t draw until the end of it has passed all of the chord symbols in that flow. This is definitely a bug and we’ll try to sort it out when we can.

Many thanks. I have a workaround in this instance (forcing a four-bar system) and alternatively I could always lose the attachment line - it’s pretty clear anyway.

Daniel, sorry to come back to this thread, but I have to disagree with your analysis of the problem:

See the attachment “Hidden Accel.dorico.zip”, a few messages up. It contains no chord symbols whatsoever but still displays the problem.

Right, that file actually demonstrates a separate but related problem.

I have that same problem in 1.2
Hopefully this will be solved in a (not so distant) future update ?

It certainly needs addressing, Marc, but I can’t promise it will be solved imminently.