Tempo Track doesn't change MIDI tempo?

Hi there,

I’ve encountered a problem getting a MIDI track to slow down in correlation to whatever’s happening with the tempo track.

Here’s the steps I’ve been going through:
1)Record midi and then make changes in the tempo track (and turn tempo track ON)
2) Activate the musical mode in the Inspector view of the MIDI track

But…no tempo changes happen to the MIDI. This works fine with audio, but not with MIDI.
I’m wondering if I’m missing something?
As I said…musical mode in the MIDI track has been activated so it’s not that…and the tempo track is on…
Might it be something in the settings/preferences?

Been stuck on this for over 8 hours…so I’d be grateful for any input…
Thanks…

Actually to clarify, if I make changes to the Tempo Track AFTER I make the MIDI track, then this happens.
If I make the MIDI track AFTER I do my Tempo track, then the tempo changes don’t register…

“If I make the MIDI track AFTER I do my Tempo track, then the tempo changes don’t register…”
Sorry, meant to say that they DO register (i.e midi changes according to the tempo track)

If I am reading correctly (after your edited post :wink: ), then what you are describing is perfectly normal…
You did this…

  1. You recorded some MIDI
  2. You made changes to the Tempo Track
  3. You then activated Musical Timebase on the track? (N.B. don’t confuse that with “Musical Mode” in the Audio Pool :wink: ) If so, then that must mean that you were still in Linear Timebase when you made the tempo changes… which, by design, allows you to change tempo without affecting the recorded material.
    In order for the MIDI to follow tempo changes, you should engage Musical Timebase before making any changes to the Tempo track.

Hi vic, thanks for the reply…sorry for the long winded explanation…you got right to the heart of the problem of what was happening though …
However, the MIDI doesn’t seem to follow the changes I’m making in the tempo track even with the Musical Timebase option engaged in inspector.
(However, if i delete the changes manually on the tempo track, the MIDI track suddenly speeds up or slows down, as if the Musical Timebase mode was working)

After a little bit more testing…what’s happening is that when I used the warp tool to make changes to the tempo track, the second that I click on the tempo track, the MIDI track changes to Linear time base.

… and when I release the mouse after making the changes to the Tempo track, it changes back to Musical Time base…

Is this a bug?

Update, and solution to the problem…FINALLY

So I worked it out myself, with a few hints from vic (thanks!)

Here’s the solution for anyone having the same problem: the time warp was in the wrong mode… I changed the Time Warp tool to the “Warp Grid (musical events follow” mode, and everything works now…

Thanks for posting your resolution, I was tearing my hair out over the last day or so with this…