Tempo Track Null Test Bug?

Hi,

I notice some strange behavior in my mastering sesion with null test using Cubase with tempo track.
Can some of you guys recreate it? https://youtu.be/6r9YS16eh3A

This has practical consequences to my workflow when I am mastering 10 tracks (one unlimited wav per track) all different tempo. First I match tempo on every track and after I am using parallel processing with Linear Phase EQs to emphasize (or de-emphasize) some elements on some parts in an arrangement by duplicating (D) track and using scissor tool and remove sections in arrangement I don’t want to emphasize.

P.S: This isn’t related on buffer size nor if I cut duplicate with zero crossing. Actually this bug also appears when I cut it on the grid so cutting on zero cross wont help.
Also this happens on windows 7 same machine with Cubase 7.5

To get better view on parallel processing check this video https://youtu.be/nlS0XC5CLNU?t=64

To get better picture on my mastering session check attached photo and pay attention on duplicated tracks (D)

*EDIT: Check post #5 for test .cpr project

Hi,

I expect your Audio events are in the Musical Mode, so you are using any algorithm for the Time Stretch. And this is the key. The algorithm works slightly different in these cases, because it’s counted from different sample.

I forgot the details about it (it was already discussed here, I would say even multiple-times), but the Time Stretch algorithm is the key here.

Hi Martin, thanks for answering.

Musical mode isn’t turned on. If you watched video I clearly showed that there is no stretching or musical mode is involved. Any other thoughts?

Very interesting. I usually dislike video bug reports, but this is very well done and shows all the details.

If I rightly understood, it boils down to this–

Duplicate an audio track with an audio event that uses only a portion of an audio file.
Set polarity to opposites on the channels
Resize event from the left, “revealing” more of the file.
Hit play– Tracks null
Add a tempo change
Resize again and hit play– they don’t null.

Thanks Steve,

Yeah you right just after adding Tempo T make sure you again duplicate tracks so avoid timebase shift. I think from video you can get better picture what is going on than from written step by step guide.

To make this easier I made test Project of this bug (8 megabytes)

  1. Please download project from my Google Drive: https://goo.gl/QPnwIL
  2. Set Snap Type from grid to Events
  3. Drag starting point of event which is on phase inverted channel to be aligned with pointer event on midi channel bellow. Please see “Drag Photo” in attachments to clear any doubts.

Thanks

Edit: Its quite challenging but I succeed to replicate bug without tempo track (also it’s disabled in transport) but its lot harder than when TT is enabled.

Does the distane of the events affect the result? Why should we put it exactly to the “pointer”? If we will not set the Start of the 2nd event here, does the phase-cancelation work?

Yes (depends on where you cut or stop start point from dragging)

Cause that’s where bug occur. “Pointer” is just a mark where its happens so you guys can TEST and report if this happens only to me or others have same bug. In practice it happens randomly even on grid you can try to hold control (or turn off grid snaping) and drag starting point randomly (like you can see in video)

As I said above there is some other points where its happening mean its NOT reserved only on that point where I marked, it can happens everywhere.

We don’t talk about some feature that should work, we are talking about major problem in core of the audio engine that according to all audio laws in digital domain (not should but) MUST work. Don’t you agree?

Just to confirm that this happens on several machines. I would really like to hear some infos from Steinberg representatives since they are not responding on my Inquiries on mysteinberg account more than a month.

I am here at disposal to provide project without tempo track on which bug also appears.

Thanks

1 Like