Terrible latency at 64 buffer setting [solved]

My template that I have spent months working on suddenly has so much latency that live playing is impossible. If I start a new project and add a VSTi the latency is fine. My UR44 buffers are set at 64. I’ve tried 96 and 128 buffers but I get the same result. I logged a support ticket but I thought I’d tap this resource as well. Anyone experience this?


If you activate the constrain delay compensation button how is it?

Wow! That seemed to fix it! THANKS!!!

So that brings to mind some questions:

  1. How will that effect my overall latency compensation for VSTi’s?
  2. Why do I suddenly have to do that?
  3. Should I just leave it on all the time?

All that button does is disables plugins with latency. So your mix should sound different.

You need to do it because you presumably added a plugin or combination of plugins that add enough latency to notice.

With the button selected you can go see which plugins have been disabled…don’t forget to check control room if you use it.

Thank you Grim. You have been a huge help!

I found the offending plugs and all is well.

Please let us know which, just so others can have some idea about what to look at when trying to narrow down their own latency culprits.

The real culprit was IK Stealth Limiter. As soon as it is enabled latency goes through the roof. I guess it’s really for mastering and not designed to be on the master bus of a mix.

A lot of these type of processors are mainly for mixing or mastering where latency is not an issue. Other processors like multi-band compressors have the same effect. It is because many of them look ahead to see whats coming at them and in order to do that, they introduce a bit of latency. I used to use Amplitude 3/4 for my guitar until I was playing with an archtop and suddenly the slap-back echo of latency was quite disturbing. In the end I bought a Kemper Profiling Amp which solved that conundrum and made Amplitude redundant.

I know what you mean. I don’t have any latency issues with guitar sims but when I switch to my GT-100 it instantly feels more immediate.

Other thing to remember is that latency inducing plugins have an effect from front to back in terms of signal chain. In older versions of Cubase a plugin that caused latency affected the whole project, now it’s only the tracks that contain the plugin.

But if multiple tracks go to a bus that has a latency inducing plugins however, it affects all tracks that go to that bus. So it’s a good idea to keep those plugins turned off, or out of your master output, at least while tracking.

Good to know.

iZotope’s Maximizers is similar. There are some settings that really tax my system. Best to switch them out while mixing, so that you can hear what’s in the mix, then in once you have the mix where you want it, and are ready to polish it.

Several plugins, like the UAD ones, have selectable tracking modes, where you can limit their latency for recording.