Text box on blank page problem

I’ve created a blank page from the Pages menu in Engrave mode - I want to use this page for Performance Notes - it will only be used for text.

I’ve turned on Frames, selected the Text Box Frame, dragged it to fill the entire blank page. However, the curser/insertion point starts half way down the page. It doesn’t seem to matter if I resize the box - I can still only enter text starting halfway down the box size.

What am I doing wrong? :confused:

Text boxes align the text vertically centered as default. You can change that in the inspector-menu at the bottom of the screen.

Hunted it down and found it - thank you! Have to select the box first, then the options appear …

Seems a bit odd that the default for text starts in the vertical centre of the page, unlike all other text editors I’ve ever used where the default is always the top … guess it’s one of Dorico’s quirky ways!

Thanks again!

Now onto the text which is frustrating to say the least - trying to over ride the defaults doesn’t seem possible at present. It seems that you can only select a preset, and that’s about it. Adjusting the size of fonts I’ve not found very successful - they always seem to revert back to the default size for that preset. Or if you select a whole passage, change the font size - it all appears to change … until you click outside the box … then all except the first line reverts back to the default size! Have to work within the confines for the moment.

If you stick to Default Text, then whatever changes you make to fonts and sizes and colours will stick… at least that’s what happens for me.

This doesn’t sound right at all. You should find that the text editing controls work just fine. Are you on Windows or Mac? What fonts are you using?

Thanks for your reply, Daniel.

I’m on a Mac.
The page of text was originally c&p from a .rtf TextEdit document in Helvetica 12pt - no formatting apart from paragraph returns.
After pasting it into Dorico, I selected it all and changed it to Default Text, Academico, Regular - no problems so far.
I then resized to 10.5pts - see pic_1. It all seems fine when the text is selected.
But when I click out of the box, things go awry - see pic_2. The top line is 10.5pts, but the rest of the text has reverted to the default 12pts. I’ve tried the same thing using the Numbers preset which has a default of 10pts. Same thing happens - when all the text is selected I can increase everything to 10.5pts. But when I deselect the text (click out of the box) all but the top line reverts to the default 10pts.
Another interesting thing I found is that if you change to a different Default, some, but not all, of the formatting is lost. Underline and bold both disappear, however italic remains. Strange, given that both the bold and italic options seem to part of the font family rather than being generic system-wide text editing modifiers.
In any case, for the moment I’ll use the closest to what need which is the Numbers preset at 10pts - 10.5pts is marginally easier to read and fills up the page much better … but, for the sake of expediency, I can live with this small compromise!

Aha, there are indeed some problems caused by pasting rich text from other applications into Dorico’s text editor, which causes the text to behave a little peculiarly. In 1.0.10, Dorico will strip out the formatting of the incoming text when you paste, which will then allow you to work with the text properly. In the meantime, I advise you paste your text into a plain text editor, then copy it again and then paste that into Dorico. There are lots of great text editors for Mac: I personally use BBEdit, but the free version TextWrangler is also great, and of course there are many, many others, including Sublime Text, Textmate, and more. I would recommend a dedicated plain text editor over the OS-supplied TextEdit as it can be difficult to persuade TextEdit to really, really actually use plain text.

Thank you, Daniel!
I suspected .rtf might have had something to do with it, but it’s great to know that it’s being addressed in the forthcoming update. Might I also respectfully request integration with system spell check … would really polish Dorico’s text handling capabilities.

Have just finished my first score in Dorico - it’s off to the printer’s tomorrow … and I’m impressed! :slight_smile: The learning curve was gentle and mostly intuitive. None of my scores have ever looked better … disclaimer I was previously working with Logic Pro’s Score Editor! While it’s very powerful, and it can do everything I need, Logic’s Score Editor is time consuming and, at times, very frustrating. The exclamations of delight (which I’m sure were clearly audible throughout my neighbourhood) are testament to Dorico’s far superior engraving capabilities. I suspect that I’ve thrown in far too many dynamics, slurs and hairpins, just because I can - it’s too easy! :laughing:

To complete the score of my current project in Logic Pro would have taken me 2-3 weeks. In Dorico I did it in 2 days. Now, if that’s not a testimonial, I don’t know what is! Sophistry aside, you can’t buy time.

Thank you Team Dorico - keep up the good work!