Text Frame Displays Token Instead Of Subtitle

Action: - Edit Master Page to include a text frame with the token {@projectsubtitle@} copied directly from the documentation.

  • Add text to the Subtitle field of Project Info dialog. Click Apply, Close
  • Go to Engrave mode. The token is displayed in place of the intended text.

Also, it’s curious that Subtitle is not a paragraph or text style.

I think we need a project for this one. Could you .zip a reduced version of your project and upload it here?

be careful not to put a space between @ and projectsubtitle

Here you go:
Riddle Song 1.dorico.zip (650 KB)

There’s a font size/style discrepancy - the “{@}” characters are at font size 16, while the “projectsubtitle” is at font size 14. If the whole token isn’t in the same font size and style then Dorico can’t recognise it as a token.

Fascinating. I first cut and paste directly from the documentation so as to be sure the text was correct. When that didn’t work, I deleted the text and typed it out. How, do you think, are the font sizes becoming different?

I don’t really know. Maybe you only deleted the bit between the end characters, or perhaps the documentation (for aesthetic reasons) mixes font sizes.

For future reference, when you want to be sure that you’re about to insert a correct token, right-click; most (all?) of the tokens are on the contextual menu and can be inserted directly.

I’ll try that. I also wonder if it’s a consequence of resizing the text in the text editor. I chose Title text as the paragraph style, and then sized it down from 20pt to 16pt.

There’s nothing intrinsically wrong with scaling text down via the text editing toolbar; you just need to ensure that when formatting tokens you select the entire token.

What I notice is that when I am editing the Master Page, the text editor does not indicate that there are two different font sizes, while if I select the token text from Engrave mode on the score itself, “–” shows under font size to indicate that there are two different font sizes. If I select the whole token in the Master Page editor, there is no such indication. If I resize the whole thing down to 13pt, the larger characters stay large. If I then select them individually, the text editor interface still indicates that the font size is 13pt. Are you able to reproduce this behavior?

This red corner indicates that you have page overrides on page 1 - you’ve dragged frames around or edited their contents on the individual page, outside the Master Page Editor. Until you remove these overrides (which can be done from the contextual menu that appears when you right-click on the relevant page in the Pages panel shown), it doesn’t matter what you change in the Master Page Editor - your edits will not affect this page (or these pages, if there are multiple overridden pages).

This is a design decision on the part of the developers: Dorico assumes that if you’ve overridden pages, you’ve done so because you meant to.

I understand, and I’ve removed all page overrides. I’m not seeing the behavior any more. Thanks for helping to track it down!

Well done for understanding despite my forgetting to add the screenshot! :wink:

This seems like an innocent mistake that I would make (it’s a “talent”!)
Maybe the developers can program it to ignore formatting codes when parsing the curly braces.

When you copy and paste from a RTF source, the font information is often included from the source and is pasted along with the text. Programs like Word have an option to “paste as plain text” if you just want the characters as though you typed them in yourself, but not everything does. I sometimes copy and paste first to an intermediate source that loses the font info (like a plain text editor, Notepad on windows or whatever), and then copy and paste from there to the destination window. When copying from Notepad the font info is not included so this two step process ensures that I do not accidentally bring some unwanted formatting info along with the text that I want.

FWIW, I copied the text from the web-based version of the documentation itself and pasted as plain text.