'The algorithm has been automatically switched to "Standard

‘The algorithm has been automatically switched to “Standard Solo” because Variaudio pitching requires this.’

This message appears every single time I go into “Pitch and Warp” and cut a segment. The message is inconveniently positioned over the top of the blobs so you generally have to wait for it to disappear before you can continue working - a couple of seconds or so.

Not so much of a problem if you’re only doing it now and then, but I regularly tune large amounts of vocals, so this unnecessary wasted time really adds up.

I can’t find any way of switching off this message and it is very annoying! Can we have this fixed please?

I didn’t check this in Cubase before posting, but I suppose the obvious answer would be to select Standard Solo as the default algorithm…

One would think so, and yes of course I tried this as the first port of call.

So in Cubase preferences I set “Default Warping Algorithm” to “Standard - Solo”. However, regardless of this setting, in the Sample editor the algorithm still comes up with “elastique Pro - Time”.

So unfortunately, changing this preference doesn’t appear to change the default algorithm in the sample editor, and so doesn’t get rid of this annoying message …

Just tried this and If I have Default Warp Algo set to Standard Solo in prefs my editors always open with standard solo already selected so I don’t get the message…so not sure what is stopping your system from making this setting…is it definitely holding the pref if you restart Cubase?

Thanks for your help Grim. Yes, have tried restarting Cubase. Cubase prefs “Default Warping Algorithm” now is set to “Standard Solo”, however default algorithm coming up in sample editor is still “elastique Pro - time”.


I’ve now raised a support ticket with Steinberg to see if I can get to the bottom of this …

Maybe an issue with your preferences file(s)? Have you tried renaming them temporarily to force Cubase to make new ones? If you can work out which one actually has that preference then you only need to rename/recreate that one obviously. Not at my Cubase PC at the moment so can’t check which one it is.

Maybe because the preference only applies to new imported or recorded audio, and you’re trying out with audio which already has the other/previous setting?


Sounds fair enough but is not the case (on my system at least)…regardless of the preferences when a song was last recorded, the current preferences overwrite it.

The preference appears to be written to the “UserPreferences.xml” file FWIW so that’ the one I’d try temporarily renaming to force Cubase to build another one and see if that solves the issue. If you’re happy opening up xml files you can find the relevant preference quite easily to see if it’s being changed when it should be.

To clarify, I was saying that changing the preference doesn’t change anything that’s already set in a project, for example, audio already recorded - which will be set to whatever the default was before. So the preference is only applied to new material created in the project, e.g. new recordings, bounces etc.

If you view the pool (Ctrl-P) then you can see what Algorithm is being used by each audio clip. You can change them all here as well with multiple selection. This is the same as viewing/changing the setting in the Audio editor.

On my system, my default was Elastique-pitch. Looking in the pool I can see that my audio clips are set to this. I changed to Standard-solo and recorded some new audio. The new audio is set to Standard-solo.


Ah yes, I misunderstood. Good point.

Thanks for all the tips guys. Personally I would call this is a bug - if the default warping algorithm is changed then it should be changed everywhere, and not left at some other value for audio that was recorded earlier or whatever.

I frequently get sent large vocal projects from other studios (for tuning and mixing), so the settings they use during the recording is up to them. I can ask them to change it but they may or may not remember.

Regardless of that, this message is simply an unnecessary time waster. One only needs to be told about it once, then there should be an option to suppress the message, just like with other Cubase messages …

+1 for a preference to silence the message.

But I don’t really agree with the preference altering the existing settings for all audio in the pool - that’s because you will always have mixed types of audio requiring different timestretching, e.g. drums which require timestretching with good timing rather than good pitch or solo.


Agreed - it should display the message once with a tickbox option to suppress it … (like many other similar messages).

Why actually can’t we access Elastique in VariAudio?

Years ago one of the mods said “Standard sounded better”. Even if that were the case then, we’ve gone through at least one new version of VariAudio and Elastique since then. Surely"Standard" doesn’t still sound better than Elastique? Or maybe somehow it does? (And why would that be?)

Good point, but I have no particular problem with the sound of “Standard” when tuning vocals - it seems very good actually. But that message coming up every single time is a complete pain in the arse!