The cursor is not always in sync

My big wish is to have the cursor in the Project window sync all the time with the MIDI Edit window on a second screen. The sync only works when you restart the playback. The cursors should be synced by default at all times, not just with the lower window but with any window on another screen.

I sometimes wonder if some of the Cubase development has lagged behind after the introduction of second and third screens.

1 Like

The cursor in the project page is always (if you have checked it in preferences) in sync with any editor. Key Edit, Drum Edit etc. I use 4 displays but for the .gif have put the project page and Key Edit page in the same monitor.

What am I not understanding? This is very basic.

1 Like

The cursor is not always in sync, greggybud. There is a certain scenario where you play a MIDI file back, note an error, stop the playback, double click the track in the Project window so that the Key Editor opens on the second monitor and the cursor is at bar 1, not bar 45 (for example) where you stopped the playback. You need to press the spacebar on and off real quick to sync both cursors.

At least, I think that’s the scenario. I’m not in front of an open Cubase project at the moment to see exactly when the cursor fails to sync. Necromorbus says to make sure the track in question is not selected. I’ll try that. On the other other hand, we have so much going on in a project’s work flow that making sure the track your working on is not selected is nuts. It goes against the basic premise of a GUI.

There should be no scenario where the two cursors are not linked by default all the time, no matter what track is selected. If I missed something here, please tell me where in the Preferences I can change this. If it’s there, I haven’t found it. Thanks :slight_smile:!

1 Like
  1. I have opened a empty project.
  2. Imported a basic midi file.
  3. Pay the midi file and stop it.
  4. Double click the part which opens the Key Editor.
  5. Everything is still in sync. I only pressed the space bar once.
    Clicking on the part, before the part, after the part. Clicking in the Key editor and making sure the cursor follows the key editor in the part syncs.
  6. De-selecting the Part and or track… as suggested above manifests no difference in sync issues here.

Are you sure you have set up a key command
Preferences…Editors…Editor Content follows Event Selection?
Or have your preferences set to reflect this?

cubase 75.8 sync editors

Thanks for the help, greggybud. I’ll look into this. I sure hope it’s pilot error on my part. You’re running Cubase 11? I’m still with 10.5.

I’ll post back…thanks again.

You are welcome. If you find the behavior still happening, hopefully you can list the reproduction steps? Of course first make sure that Editor Content Follows Event Selection is checked.

Trust me. I have many pilot errors. I’m still discovering new gems to enhance workflow.

Okay, I was able to reproduce the problem. Please read on.

My sample project has Piano and Bass MIDI tracks. The song is 140 bars long. I’m using two video monitors. Monitor 1 is for the Project window. Monitor 2 is for the Key Editor, Mixer, Drum Editor, and other auxiliary windows.

Scenario

  1. In the Project window, select the Piano track.
  2. Press Play and let the song progress to Bar 14.
  3. Double-click the Piano MIDI part and the Key Editor opens. Piano cursor is in sync at Bar 14. Fine so far.
  4. In the Project window, select the Bass track and look at the Key Editor. The Bass MIDI track is displayed, but the Key Editor only shows Bars 1 to 10, the maximum number of bars shown on my monitor before Auto scroll kicks in.
  5. The cursor is still at Bar 14 in the song but not visible in the Key Editor Bass track until I press Play, hence why the cursor “appears” to be out of sync. It actually is in sync.

Auto scroll is the culprit here. So the cursor is always in sync but after you select a different track the Auto scroll doesn’t “catch up” in the Key Editor until you press Play!!

So, when I’m editing the Piano track at Bar 125 (for example) and then switch to the Bass track, Bars 1 to 10 are displayed for the Bass track in the Key Editor. Meanwhile, the cursor is still in sync at Bar 125 - no problem, but to edit the Bass track at Bar 125, I need to press play! Hence, why I thought the cursor wasn’t in sync all the time. It actually is. It’s just not displayed because of the way Auto scroll “restricts” the displaying of a different track in the Key Editor window.

Now what?

So essentially, Auto-Scroll only works on the active/focused window.

AS @greggybud has pointed out, The playback cursor is in sync with all open editors, focused or not.

To help get the workflow you’re after try this:

Turn off Editor Content Follows Event Selection, to allow multiple editor windows to be open.
image

If you leave the editor windows open, double clicking on a midi part will open the editor with the cursor in view. The windows can be full screen, side-by-side, or cascaded. Any way you do it, when you open the midi part, its editor will be brought to the front, with the cursor in view.

The first time you open the editor you might have to do A quick double tap on F ( auto-scroll ) to get the cursor in view, but hitting play isn’t necessary-- you don’t lose your place.

Also, you can make a macro to open the editor with a keystroke, and toggle auto-scroll twice.
image

No, Sorry. This is not correct. see above.

Hi Steve,

Your solution of unchecking Editor Content Follows Event Selection works! The only difference is, I need to double click any MIDI track that I want to see in the Editor (like you mentioned). It appears in the Editor at the exact spot.

With the box checked, you can just single click another track but if the cursor is anywhere past Bar 10, you have to press Play. So, problem solved! The Auto scroll works too. I leave it on all the time.

Many thanks to all! I’ve hated this issue since Day 1. Looks like it was pilot error :roll_eyes:.

1 Like

Well, in fairness, there are like a gazillion pref combinations possible for this. (Which is what makes Cubase useable for such a wide variety of user workflows)

Agreed, Steve. There are a million ways to configure Cubase.

Thanks again, all :)!

Please, don’t let this topic go off the rails. The discussion is about this feature, not the documentation. Please start a new discussion.

The Auto-Scroll command back to back 2 times in a macro looks weird. But it works. I have used it for a few different zooming type macros combined with other key commands to get where I want to be more quick.

Someone hungry for YouTube money should make a tutorial about this issue.