The 'delete beats' documentation does not seem to work

I have a 2/4 movement with 1 eighth of a pickup measure and so I’d like to delete 1 eighth from the last bar. I’m using Dorico Pro 3.5.12 and so I’m trying to follow this documentation: Deleting bars/beats

But, taking it completely literally, it just does not seem to work. I recorded a video:

I’m doing 2 things in that video. First, I’m following the instructions to the letter: I select ‘an item at the rhythmic position from which you want to delete beats’, that is, the last eighth rest, ‘Press Shift-B’, and ’ Enter – (minus), followed by the number of bars or beats you want to delete into the popover’, that is ‘-1e’. Nothing happens. (Thinking that Dorico might require me to input ‘-0.5q’, since there are two quarternote beats, I also tried that, without recording, but it also has no influence on the score.)

I then, just for kicks, select the last eighth note in the left hand and do the same. To my amazement I notice that after me inputting ‘-1e’ Dorico does not delete one half of a beat: it converts the sounding music to rests, and the number of beats stays the same! This also seems incongruous with the documentation, since what ‘Shift B -1e’ really does here is change the content of beats (changing an eighth note to an eighth rest), and not the number of beats (i.e. it does not delete any (portion of a) beat). Interestingly, here, in the left hand, after selecting the last eighth note ‘Shift-B -0.5q’ produces no visible result.

What am I doing wrong?

Things get finicky at the end of a Flow.
Select the last eighth rest,
type <shift>B
then type final in the popover

1 Like

Please see Trouble removing beats from bars - #5 by Lillie_Harris

This particular bit of documentation is due for a revision at some point.

This bit of documentation was unfortunately not accurate, it came up a little while ago from another user. Dorico won’t leave a partial final bar this way. I’m sorry for the confusion! I always check everything I write, so that was either briefly true but is no longer or I was simply mistaken.

It’s been corrected in-house since the 3.5 manual was published, as you can see here in the iPad manual. Again, apologies for the misdirection - adding an explicit barline and removing the final bar after the barline, or adding a time signature with fewer beats for the last bar are both available alternatives.

1 Like

Thank you very much for all the answers! I marked @Craig_F 's as a solution since it’s overwhelmingly practical. [Note to future self and perhaps some others who stumble upon this thread: if you’re setting an AABB movement with a pickup measure, just write out the whole bar in which the repeat sign is to be put, select its intended position and use ‘Shift-B endstart’.]

@Lillie_Harris , thank you for the documentation link. I have to say I don’t see how the Ipad documentation improves things! I’m very sorry, maybe I’m just daft here, but perhaps this might be useful as a ‘user experience report’.

But also let me note that I agree with @benwiggy 's post in the thread linked by @pianoleo above, that the probably unwanted behaviour takes place not only in a final bar of a flow; that is, in all other places I checked, ‘Shift-B -1q’ does not remove a quarter beat, it just deletes a beat of music and replaces it with rests. (I.e. the duration of a bar does not change; the Insert mode does not modify this behaviour.)

There’s a note at the end that explains what’s different about deleting essentially a partial final bar, with recommendations of other things you can do instead and links to those things.

When deleting less than a full bar anywhere, you should see the change at that point in the music (ie subsequent music moves up) but the final bar won’t be removed unless you delete enough beats to remove the whole bar. In an open meter, this doesn’t apply of course. The reference is made to the final bar because that’s where the end result of changes essentially takes effect.

This is what I find to be misleading about the way the situation is described in the documentation. In the sentence I’m quoting, notice that you’re first talking about ‘deleting less than a full bar’, but end up talking about deleting the contents of less than a full bar.

(I) If I “delete a quarter beat from a 4/4 measure”, I expect to end up with a 3/4 measure, since this is what “deleting a quarter beat” taken literally would lead to.

(II) In contrast, if I “delete a quarter worth of music from a 4/4 measure”, I expect to end up with a 4/4 measure, with all the “subsequent music moved up”.

It seems the documentation speaks about (I), but the real behaviour of the ‘delete beats’ command is (II). I find this confusing.

(As always, thank you for taking the time to replying!)

I can see why you’d expect to end up with essentially a 3/4 bar if you delete a quarter note from a 4/4 bar, but that’s not what happens. However, if you delete 4 quarter note beats, both the contents of a whole bar and the bar itself are deleted, so it’s not only about deleting musical content but also rhythmic time, provided the rhythmic time matches up to at least one whole bar.

I’ll make a note to see if clarifications can be made that don’t end up confusing the matter further.

Please note also that deleting measures works differently from deleting beats. ‘-1’ actually removes 1 measure (it does not fill it with rests). In contrast, ‘-1q’ actually fills 1 quarter beat with a rest (it does not remove it EDIT: I WAS WRONG HERE: it actually ‘pulls the music to the left’) ENDEDIT. As a user I find this confusing and I don’t know why the word ‘delete’ is used in both places. (I mean, I’m glad you told me this is intended behaviour, thank you again! – I’m just reporting this because maybe it might lead to removing this inconsistency?..)

That’s not what I experience - I find that using the bars and barlines popover and removing e.g. -1q deletes that beat entirely, and does not leave rests - unless you’re removing the last beat in the last bar, in which case that is what it looks like.

Have you got a project where removing a beat using the popover in the middle of the flow or similar leaves empty rests behind, i.e. subsequent material isn’t pulled forwards as a result?

Apologies. I managed to confuse myself 100% on my own this time, it’s not the fault of the documentation.