The ‘dot’ key not working as expected

Hi,

I am reading through Getting started with note input and in the second page (Section: Violin 1 ), we read:

The ‘dot’ or full stop key is the rhythm dot, so press 8 G T G T 7 . G for two whole notes and a dotted half note all tied together.

As you can see in the animation, after I press full stop key, it places a whole note tied to previous one.

fullStopKey
Note: I have set the note input default pitch “After duration” in the preferences page.

What am I doing wrong please?

When I tried the same key sequence ( 8 G T G T 7 . G ), it resulted in this:
Ties

To get the same result as you did, I had to press 8 G T 9 G T 7 . G or or 8 G T G T G T 7 . G

It looks like the caret advances four times (with a note added each time), which would indicate to me that you’ve pressed G four times, as @stevenjones01 has described. Are you positive that you haven’t pressed an extra one before the dotted minim?

Yes I am positive, I pressed G ONLY 3 times. I did try it agin.

I restarted Dorico and redid it. Same result :unamused:

Ok cool. I also cannot reproduce this. The video looks to me as though you’re entering separately:

  1. a G
  2. another G, tied
  3. another G, tied
  4. dotted minim G, tied

(with the caret moving for steps 2-4)

If you don’t mind me asking, can you describe what you’re pressing for each added note? Sorry if I’m going crazy?!

Here is the screenshot with keystrokes! I hope I am not doing anything stupid!

As you see, as soon as I press the . key, it places a Whole note!!

fullStopKey

Three questions, to help troubleshoot this odd situation:

  1. What do you get if you press 7 . G ?

  2. What do you get if you press 8 G T 7 . G ?

  3. What do you get if you run through the sequence of key-presses but without using the T key ? ie 8 G G 7 . G ?

1 Like

And have you customised any shortcuts?

1 Like

No! I just installed Dorico Pro 4 and have not updated any preferences!

Sometimes similar problems arise because of a mismatch in language settings.

What physical keyboard are you using?

What keyboard layout (eg English, Japanese, German, etc.) is chosen in your System settings?

What language is chosen in Dorico in Preferences > General > Language ?

  1. What do you get if you press 7 . G ?

half note G in the first bar ( caret at the beginning of the flow)

  1. What do you get if you press 8 G T 7 . G ?

8 G T 7 . : I get whole note in the first bar tied to a half note to the second bar.
8 G T 7 . G: A whole note in the first and A whole note in the second bar to a quarter note in the third bar; all tied together.

  1. What do you get if you run through the sequence of key-presses but without using the T key ? ie 8 G G 7 . G ?

What keyboard layout (eg English, Japanese, German, etc.) is chosen in your System settings?

US ( Mac OS Mojave)

What language is chosen in Dorico in Preferences > General > Language ?
English.

7 . G should give you a dotted half note

7 = half note
. adds a dot to the note
G = inputs the note G with the value which was specified by 7 . ie a dotted half note.

Any chance you have switched your input mode to “Pitch before duration”?

2 Likes

It is set to pitch after duration. It was the second option.
I change it from after inputing note to before inputing note and it does work now the way it says in the tutorial note.

2 Likes

Thank you, Estigy and other folks for helping out!

3 Likes

That’s what the forum is for!

I expect at some point you might have hit the K key, which toggles between duration before pitch and pitch before duration. This does light up one of the buttons in the toolbox on the left-hand side of the window: try hitting K a few times to see which icon lights up, and then you’ll know what to look for if this happens again in future.

1 Like

Thank you, Daniel.

You’re welcome! :joy:

1 Like