The Grand 3 SE Effect Issues

I just launched my trial version of this software and am having trouble selecting effects in the "ambience’ tab. Whenever I change the effect the effect actually doesn’t change. The only way I’ve been able to successfully make them change is by loading a preset with a different effect. It will load THAT preset’s effect but once again I am unable to change the effect in the ambience tab to another effect other than the preset’s.

Has anyone encountered this? I have already looked into the knowledge base with no info on this issue.

To be a little more specific. I can change the effect in the ambience tab…however the effect itself does not change, if that makes sense. It will say Dark Concert Hall but the effect will still sound like the preset’s effect such as small room, etc.

Has anyone tried doing the above? I still can’t get effects to work inside of The Grand 3 SE… Kinda makes it difficult for me to justify spending $99.

I tried to open a ticket to have this looked at using the form on After I completed the form it went to a 404 page so I have no idea if my ticket was created for someone in support to look at it.

Any help please?

As has been discussed in the Bug thread, I’m bumping this to be looked at…

Posting computer specs:

Mac Intel 2.0 Ghz Dual Core (circa late 2006)
2 GB Memory

Bumping again. Please have a look at this issue.

Here we are again…

This can’t be that hard to verify as a bug?


checked here and no problems. Perhaps somebody else ?



I just reformatted my Mac and will be reinstalling everything. Will see if this situation changes with a fresh install.

Somehow reformatting and reinstalling fixed it. Probably didn’t have to do all of that, but wanted to anyway…