Thinking of buying Retrologue 2 for Cubase 7.5 - will there be licensing issues?

I use Cubase 7.5 (works fine and is stable - Cubase 12 does not offer me any extra value).

I am currently running the “built-in” Retrologue in Cubase 7.5. It is very good but I’d like the extra features found in the current Retrologue 2.

The problem is - I’m running Cubase 7.5 on a Steinberg USB dongle and I’m concerned that installing Retrologue 2 will

a) overwrite my previous presets (it overwrites the previous version of the VST) and/or

b) require me to use their confusing online licensing system to register the new version (I think? Please correct me if I’m wrong…)

I already have the Steinberg bloatware that came with the Cubase 12 demo - that was nearly a disaster as it overwrote tons of stuff I was still using. It took a month to get everything back to normal.

So I’m a bit concerned about upgrading. Any thoughts or advice you could give me to ease the process of upgrading to Retrologue 2 in Cubase 7.5?

Ta muchly!


New Retrologue 2 licences will be issued on Steinberg Licensing.

Have you thought about upgrading to Cubase 12 and continuing to use an older version? Your dongle will upgrade to a non-upgradable Cubase 11 licence (which will continue to work with older versions so long as you are on an operating system that still supports eLicenser database updates) and you will get a Cubase 12 licence on Steinberg Licensing. Both the eLicenser Cubase 11 licence and the Steinberg Licensing Cubase 12 licence will enable Retrologue 2 so long as you are on a Cubase edition that includes Retrologue 2.

Hi David

Thanks for the prompt reply!

What you suggest IS logical but after my previous experiences installing the Cubase 12 demo and all the damage it did I can’t afford to risk it happening again for now. I’d rather just have Retrologue 2 on its own! I can’t risk losing work again.

I’m “guessing” I’ll have to update all the Steinberg software I had to download when I tried Cubase 12 so that I can run Retrologue 2 on Cubase 7.5 (on Windows 11 by the way). Then I’ll just keep the dongle connected for Cubase 7.5.


Spent the last hour bouncing all Retrologue 1 material to audio just in case Steinberg broke it.

Bought Retrologue 2 (at £43 so much cheaper than an “upgrade” to Cubase 12). Steinberg really need to increase their bandwidth - I kept getting pop up “error can’t connect” messages.

Anyway after downloading their 254 software addons (OK I jest but surely just ONE would do Steinberg?) I now have a WORKING copy of Retrologue 2 - with intact original presets.

I now need a larger monitor for all the Steinberg shortcuts adorning my desktop…

UPDATE 2: I knew there had to be SOME issue with this software - all the default presets are missing (or were in my case).

SOLUTION: Despite the Steinberg Download Assistant having a window saying “DOWNLOAD ALL” I think there must be something lost in translation. It didn’t download the preset content so I had to do that manually. Once I’d done that the presets magically appeared.

Another hour wasted. That will be £250 please Steinberg :slight_smile:

I’m glad this VST only cost me £43 - the bugs are starting to appear thick and fast.

Why can’t I play these default presets in the browser and what does the red sign indicate? In the UK it means “NO ENTRY”!

It seems that these programs are not licensed to run. Maybe they are included in some kind of paid expansion?

They’re part of the content not a paid addition to the library.

You have to set up your MIDI controller properly and untick “ALL MIDI” (which I did).

The controller has the correct software installed (NEKTAR LX61 keyboard).

I’ve checked the location of the MPE preset file and it is in the correct location according to the Steinberg Library manager. The VST is activated. I’ve even reinstalled and AND re-downloaded all the content via the download manager but they’re still not playing a sound. There’s just a red symbol against all the MPE presets. All the default presets are working fine.

Steinberg if you’re monitoring this forum I need your help please!

The do-not-enter sign means they are not licensed and nothing else.

As far as why, one cannot know without more info from you.

What is its name?

Seriously, what are you referring to?

Hi Steve

The name of the MPE preset file is


It’s 326kb and in the default VST SOUNDS folder as defined in the Library Manager, as are the other preset files for Retrologue 1 and 2 (I’m running on Cubase 7.5).

The last comment was in anger after wasting two hours last night attempting to get Retrologue 2 to work properly;)

I don’t have Cubase 7.5, so I can’t help you figure out the problem.

Possibly, you need to use the Activation Manager though. But I have no real idea.

I’ll merge this with your other topic about this.

Well I have given up for now. I’ll have open a support ticket and hopefully get a response before Christmas.

Thanks for the suggestion re the activation manager but I tried checking that a number of times and all is apparently normal and activated. However the MPE presets still don’t work.