This is the third time I have to redo engraving

Dear fellow Doricians and Dorico Team,

This is the third time I have to redo the staff-spacings for a 58-page Piano Trio that needs to be sent to musicians ASAP (for a recording in June for Signum Classics). So, I finished working on my full score and I got to work on the individual parts. After I was done with the violin part, I went back to the full score only to realise that the whole spacing and engraving had been reset! :astonished: And there I go again! Then, I did that for the second time and went to work on the cello part, only to realise after I was done that the spacing had changed yet again in the full score! So, this is the third time that I have to work on that this week. (This happens even if I’ve already locked all frames and systems).

Now, I realise that I can export a PDF, which I did. But if there is a single “p” dynamic that I want to change to “mp” I still have to go to Dorico and make that change. And if I do, then I run a high risk of the whole thing changing on me yet again and having to work on it a fourth time.

I find that Dorico does almost everything to perfection, but you have no idea how many times I thought: “If only there was a way to literally freeze everything once I’m done.”

Please help!

What version of Dorico are you running?

If this happened to everybody using Dorico there would probably be a few hundred posts here complaining about it.

So, most likely it is either something peculiar about your score, or some misunderstanding about how to use the program. Either way, it’s hard to make any suggestions without a score that reproduces the problem - and some instructions about exactly how to reproduce it, of course.

To clarify, I’m asking what version the OP is using because there was a bug whereby Dorico “forgot” staff spacing in 2.0. It was fixed in Dorico 2.1

I have to say, I’ve never seen anything like that. Each Layout is entirely separate.

Are you sure that you didn’t alter the Layout Options for the Score, and not for the Parts?

Staff spacing adjustments are tied to the rhythmic position (i.e. which bar and which beat in that bar) at which the system begins. Provided you don’t make a change to a layout that will cause its system formatting to change, then any staff spacing adjustments will persist – and even if you make an edit that causes the start position of a system to change, only the adjustments on that system will be removed: it won’t remove all adjustments everywhere, unless the rhythmic position of the start of every system changes.

Hi, everyone! I’m running Dorico 2.2.20. To be clearer: when I worked on the Violin Part I changed a few dynamics and some hairpins to crescendo text markings and the like, nothing too intense. Some of those changes were reflected in the Full Score, of course, which caused the software (I assume) to recalculate the spacings and start a chain reaction. At least, that’s my explanation. Yet again, I wish there was a way to “freeze” a specific layout or something like that… I appreciate your concern and help, though.

Just because you’ve specifically mentioned changing dynamic types:
If you delete an existing dynamic in one layout, Dorico may recalculate things in another layout.
If you add a new dynamic in one layout, Dorico may recalculate things in another layout.
If you want to change a hairpin to a textual dynamic or vice-versa, select the existing dynamic and change its Gradual Style in the Properties panel. Not only will it not recalculate the other layout; it won’t even update the gradual dynamic style in the other layout (until you go Edit > Propagate Properties).

Hi, Pianoleo! Yes, I used the properties panel to change the hairpin to a text dynamic, but I wanted that to propagate, so I used the Edit > Propagate Properties. There must be a way to avoid Dorico recalculating everything, though… That’s just my opinion, though.

One thing that has gotten me into trouble before has been the justification settings for various layouts. Sometimes Dorico will want to add space and then bump a stave to the next page, thereby going from 3 staves to 2 on a pace (for example) and totally changing spacing. Turning this off helps sometimes. This (de facto) cannot happen if you have your formatting locked, however (or on the rare occasions where something odd does happen, it is thereby confined to 1 page). One feature I wish would be honored in future versions is: in vertical spacing mode, if I set a specific value by typing it in and it changes the handle to red, I’d like that spacing to still be honored even if the stave ends up on a new page. If there’s a manual override, I don’t think that should ever be ignored or reset unless express permission is granted by the user.