This is weird: midi keyboard issue


I am using Cubase 7.05 64-bit wit my Novation Nocturn keyboard and Win7 64-bit.
The setup has been working ok until I tried to set up Nocturn with the new VST Instruments controller. I do not actually know if this started it.

When to want to play a VST instrument, I can see there is a midisignal from the transport control, but no sound. Then when I create an empty midisection and double click to enter it, I can suddenly play the VST instrument from the keyboard.

Did i accidently push or tick something I should not, or is this a bug?

I don’t know which VST instrument you’re referring to, but off the top of my head, some VSTi’s need to receive CC11 (expression MIDI signal) to sound. Set one of your knobs/sliders to send CC11, turn it up and see what happens.

Good Luck.

make sure the track is record “armed” it is not by default after creation but as soon as you click on the midi part you are selecting that track with “arms” it.

AFAIK, “Enable record on selected MIDI track” is ticked by default in preferences (under Editing, under Project and MixConsole, but if it is NOT ticked, you might like to do it to save time. Selecting a MIDI or instrument track to record into is too basic not to know! Thanks for bringing this to attention though.

Ok, here is the clue; you were right, I had ticked off “Enable record on selected MIDI track”.
I did it because everytime I was recording from Mopho Keyboard into a audiotrack, I wanted to go to the Mopho vst to turn some knobs while recording, without enabling that instrument track for recording too. Mopho is not in the same room, and I didn’t figure out yet how to set up Novation Nocturn with the VST instruments controls. The whole situation is a little awkward :slight_smile:

I’m really emberrased I didn’t figure this out, but at the same time I don’t understand why I have to enable record just to play an instrument?

Thank you!

You really don’t have to enable the record button to hear what you play. You can instead enable monitoring (the smaller round button right next to the record enable button). This way your track will not record anything, but you can hear what you play. After all you have to enable “something”. :wink:

And no need to be embarrassed. This forum is here to learn from. :slight_smile: