This thing with "transpose 0" appearing in the score

Cubase 10.0.x (didn’t bother to try 10.5) Windows 10 2004

Whenever a piece changes key and the change happens to be to Cmaj (no sharps, no flats) AND that change happens to be at the beginning of a new staff in page layout mode, you get an annoying “transpose 0” indication at the beginning of the new staff where the key change takes affect.
I usually try to “hide” that “transpose 0” text, but that will cause the entire key change to be invisible when the score is laid out again and the key change does not happen anymore at the beginning of the staff.

As a serious side note: Sometimes I ask myself why I’m still reporting these issues here, I guess I still haven’t lost all hope. Music engraving only programs do not work for me

The developer must have his reasons for making this text display, but honestly I do not see the point. :unamused:

Anyway you can safely hide those texts without any side effect.
And in any case the “transpose 0” text won’t be printed. It’s supposed to be a display “helper”. (though it sometimes moves the bur number)

To go further, this text displays because you have Global Keys enabled for your score.
In order to prevent this text to appear, you have some options such as:
Right click on the key signature and uncheck “Key Changes for the Entire Project”.
Or in Score Settings>Staff>Main you’ll have to play with the Local Keys option.
There is also an option in the Notation Styles in the Score Settings/Project tab.
The Display Transpose setting in Score Settings>Staff>Main also affects the appearance of that text.


Reporting issues here is important. The Score Editor is still getting attention and improved. There is no need to be pessimistic right now.

Even though I am familiar with major scoring programs in the market, I still prefer the intuitive way the Score Editor works, even if it does not have all the sophisticated features of the other ones. And on top of that, being powered by Cubase is just unbeatable!

Anyway you can safely hide those texts without any side effect.

Well that’s not true: hiding this texts will make the entire key change invisible in some situations, and cause the musician play in the wrong key.

But anyways thanks for your uplifting reply :slight_smile:

I’m not seeing this.
Which situations? Can you give an example?


Here is the piece with the “transpose 0” texts hidden, for the example’ purpose i’ve turned on to show hidden stuff, so you’ll notice the “hide” where the texts used to be.

The 3 naturals are still there so everything looks okay. UNTIL you decide to do a redistribution of bars for layout reasons, then you will notice you’ve actually hidden the entire key change:

For this example I’ve turned on to show the hidden stuff, but usually that’s not the case.

But you are right, the texts do not print out - so I will put this on the (growing) list of things to ignore :slight_smile:

Ok, then you just need to remember to unhide those elements after changing the number of bars.
And the text does not print out but you’ll have to manually ajust the bar number position that it often shifts to the right.
In a nutshell, again, in my opinion, this “transpose 0” indication in the score seems utterly useless.

In a nutshell, it’s a technical glitch/bug that started about a year ago

It’s been there for much longer than that: more than 10 years, as far as I know :confused: