Thunderbolt II VST Rack not connecting

I have recently just switched from Firewire 800 to Thunderbolt II using Apollo Duo. Running Cubase 9.01 when loading my template with VEP Pro 6 or internal VST Instruments hosted in Cubase or VST Rack with VEP 6, I found an issue where Midi or connectivity does not send data to the VST instruments or VST Rack instruments. I have tested by loading Knotakt as a VST Insturment as I thought it was an issue with sending data (MIDI) to VEP Pro, but found that it doesn’t even initiate the loaded instrument in Kontakt and loading a sample like Spitfire or Berlin VST, Kontakt does not detect a connected VST Bridge so the Instrument does not connect.

Now midi is working as you can see midi data transmitting from the MIDI keyboard and the channel also indicates MIDI activity. But the VST Rack or Instrument does not indicate MIDI activity. Looking in VEP 6 there is also no activity either.

Further Testing, I do own Studio One Pro version 3.3 and I loaded my template in Studio one, and everything loads just fine and connects to my instruments and everything plays correctly every time without issue. I cant explain it. If I run studio one and then shut it down, and then load Cubase 9 it will sometimes resolve the issue. But its not all the time and I am at a lose. When using Firewire 800 out of the Apollo, there was no issue. So I am not sure if I am missing something but I think there is a bug. Please let me know what you need in order for me to assist you.

Further testing: I loaded Cubase 8.5.20 and it also works without issue. Everything loads just fine, but 9.0.1 doesn’t…I am completely confused what changed. I have only had it working a few times and right when I think I understand what the issue is, it proves me wrong. I really want to get this working or figure it out because I really love Cubase 9 and its layout now. I guess I could use Firewire 800 out of the Apollo but I waited and worked hard to get thunderbolt working. It just doesn’t make sense that it would be the thunderbolt though it was the only thing that changed.

Also, I have verified that all my drivers and chipset drivers are up-to-date. I just wanted to make sure. But since Cubase 8.5.20 and Studio One 3 work, it has to be something else.

Please let me know if there are any files that I can provide that may assist you. I am baffled as to what to look at next.

Thanks everyone for your time.

Another update on this issue:

Deleting this post as that was not the issue. Uninstall and Re-install did not solve the issue. It appears to me that something in the audio bridge is not actually syncing with the drivers. Audio imports do not play, Cubase VSTs do not play nothing. N sound. Only Signal I see is Midi activity in the Midi Monitor. I am about to give up on this. There is something about the Thunderbolt, though as stated, Cubase 8.5.20 works without issue, Studio One v3.3 works without issue and all other audio works without issue, be it standalone VST instruments, windows media…I think you get the point. Any assistance?

I found the problem, something in my preferences is all jacked up. I have no idea what, but now things are working. But now I need to figure out how to get my template back which I spent forever making to not use whatever is messed up. You can pretty much ignore this issue now as its not one.