Time Handles in Logic - How to do this in Cubase?

In the piano roll editor in Logic I can activate ‘Time Handles’. I can select an array of notes and stretch their position proportionally. (E.g. you can turn 8ths into triplets very easily).
Can anyone tell me how this can be achieved in Cubase?

Currently not possible.

As @ozinga said, but as a workaround, maybe something like what follows could help, using both a macro and the Logical Editor. It’s rather complicated but well, it is seems to work, here, on a set of notes already selected in the Key Editor :

  • First, the Logical Editor processing (mandatory : it should be saved as a preset - I have saved it as C11030_ShiftPosition), with a bunch of MIDI notes selected (onto which the process will be applied) :

  • Second the definition of the macro associated, names Test_ShiftPosition :

C11030_Macro_ShiftPosition

  • Third, the same MIDI events after being processed by the macro :

The main problem is that the Logical Editor preset created doesn’t appear immediatly in the list of the already available ones in the Key Commands window. Don’t know why, but I had to save and close the project, then Cubase and reopen them all to make it appear. Beside this, it more or less seems to work as expected, I think : the notes that were at these positions :
20.3.1.0 / 20.3.3.0 /20.4.1.0/20.3.3.0/20.3.1.0
… are brung to these :
20.3.1.0 / 20.3.2.40 /20.3.3.80/20.3.2.40/20.3.1.0

HTWH as, if you find this workaround useful, it will surely need further adjustments to your needs…

1 Like

Thank you! Super helpful!

Even though I am new to Cubase, I was able to figure out your process and now I can make a set of macros to perform a variety of these modifications. I added a key command and now I’ll put on my StreamDeck because this is something I use all the time as I love to experiment a lot with polyrhythms.

Now, I realize that the action is always performed relative to the beginning of a region, but not the cursor/playhead position though the commands chosen in the Logical Editor/Macro would suggest that it would start at the cursor. In other words: If the selected notes are not at the absolute start (left edge) of the MIDI region, the entire selection shifts including the first note, as ideally the first of the selected note should not move, only the following ones.

Is there another way to encourage the action to be performed at the cursor position?

Could be, by making a previous selection with a command such as Edit > Select from cursor to end. It would need added tests to confirm it, though. I’ll try to set something with it tomorrow and will let you know here, if I find something useful…

Thank you so much. I would love to hear from you if you can find something!

I tried out adding these commands to the macro:
Locators to selection
Go to Left Locator
… but that did not help either.

Another workaround would be to do this in the Project Window and not the Key Editor. You’d need to cut up your existing MIDI Parts so that the Notes you want to stretch and only those Notes are in their own Part. Then use the “Sizing Applies Time Stretch” option on the Arrow/Selection Tool to lengthen or shorten the Part and the Notes will stretch and shrink with the Part. When done you can glue the resized parts back together if it matters to you.

2 Likes

Thanks for pointing out this alternative. This might come in handy for some situations.

What I see is that in this method the actual length of the notes are affected as well. That might be good for some things and less desired other situations (e.g. a piano score)

Hi again, Crescendo

I think I have a first solution which works, as long as you keep selecting the notes that need to be processed, the first one in the timeline supposed to remains where it is. Actually, it involves a marker and just consists of the addition of two lines in the precedent macro, as shown :

C11030_Macro_ShiftPositionB

AFAICS, the only problem is that the marker remains and is visible if you have a marker track already displayed. I’ll let you know if I find something more elegant (I haven’t found the way to delete a marker with a key command, yet - there should be a way…). But the essential remains, I think, as the cursor stays at its initial position.

Hope it’ll be useful…

When I test it out here it looks like the selection still jumps to the right in its entirety (in addition to doing the correct thing). I think it will need a little more experimenting…

Here’s another way.

Set quantize to desired length, then

  1. Do command:
  • MIDI: Fixed Lengths
  1. Then select fist note in series

Then run this macro as many times as needed:

  1. Transport - Locate selection end
  2. Navigate - Right
  3. Edit - move to cursor

Result:
Change lengths

The selection… You mean the cursor ? I have tested it again and there’s no jump, here : it stays where it was before launching the macro… Are you sure of the lines order in the edited macro (I ask this, as I made the mistake recently, adding a line at a wrong place…) ?

Yes, i checked the order of lines in the macro. It looks correct.
I made a screen recording, but this forum does not allow me to upload it.

Another helpful spirit!
Interesting, what do you mean by “Do command”? I have set the Quantize Length option, but there is no “command” in sight, can’t find a menu item either.
I would like to give it a try.

In Cubase the term command means a Key Command or a menu item that invokes a function.

A macro is a sequence of commands that can be run via an assigned keystroke.

I probably just wasn’t clear about the terminology - I have put together macros before. I also got it to work now.
Interesting thing, it only seems to work when you intend to have each note connect to another. I guess that can be remedied by a second step. The good thing seems to be that I won’t need to set up x amount of macros for different lengths.
Great to learn about all the possible options when at first it looked like there is nothing available.

Hi again, Crescendo

Could you post a screenshot of the lines composing your macro ? I have just tested it again, using the exact modified macro posted previously : no jump of any kind, either from the cursor or the selection and this, even with the Snap On and set To grid. Using these parameters in Logical Editor (and saving them) :

I start from this :

And obtain this :

So, I’m afraid not being able to improve it, as working as you expected, I think…

EDIT : you shouldn’t need different macros to use it, as the eventual variations needed are actually done in the lower pane of the Logical Editor and can be done on the fly and saved under the same preset name.

I think I found it out. Instead of a multiplier and a divider in tandem I had set only a multiplier (x1.5) in the logical editor because I thought that would just do for stretching the selected notes out by one and a half. Obviously it needs both a multiplier and a divider. I changed it to that and not it works.
I still will have to experiment with different settings.
Thank you for your help!

Reassure me : I should read this, I guess ? :innocent:

Beside this, I have just tested the whole thing again, but as you, with a only a multiplier and it also seems to work as expected (I put both multiplier and divider, at first, as it seemed to me more adapted for a direct musical translation and haven’t thought about it further). Strange… :thinking:

Feel free to report back again any eventual issue… :slightly_smiling_face:

Hi,
Not sure I understand your question correctly. If you wanted to change a group of midi notes from 8ths to triplets, wouldn’t you just lasso the notes in question and quantize them as triplets?