Time signature won't change

Hi,
for some unknown reason (at least to me) I can’t change the time signature on bar 29.
It is changing visually, i.e. the number is changing, but not the actual rhythmic width.
Exaltation.rar (340 KB)

Hi,
I have quite the same problem…

qanunji, I haven’t looked at your project yet, but I replied to dansegre https://www.steinberg.net/forums/viewtopic.php?f=246&t=122145&p=662760#p662760. Does that explain the issues you are seeing?

Thank you, Stefan, but why it is not a consistent behavior? as on many other bars, I 'm able to change the time signature without being in Insert mode.

This behaviour is consistent with the way other Insert mode operations work in note input. Dorico doesn’t know what your next move is going to be, so it can only go one step at a time. It would sometimes be exactly what you don’t want that it changes the length of the bar right away. By allowing you to choose whether time is inserted (because you’re e.g. not going to delete the following time signature) or whether it is not (because you are rebarring all of the music and you are going to delete the following time signature), it puts the control in your hands.

thank you, Daniel, but maybe I wasn’t clear enough, or I didn’t understand your answer:
The behaviour in Insert mode is consistent, and I got it.
I’m talking about the regular input mode- sometimes it behaves like Insert mode and sometimes not.

I’m sorry, but I don’t really know to what you’re referring: if you can provide a bit more information about what you mean, e.g. with a specific case where you feel like Dorico is behaving as if it’s in Insert mode when it isn’t, I’d be happy to try to explain further.

for example, look at bar 2 at the project I’ve attached at the post-
when not in Insert mode, you change bar 2 to 4/8, or 14 /8, but not 6,8 for some reason.

Same issue. Can insert a 9/8 time signature but still only 6 beats in the bar. This should not be difficult.

If there’s already a time signature after the one you’re trying to change, you’ll need to turn on Insert mode before changing the 6/8 to a 9/8. Alternatively you can input the 9/8 time signature then put the caret where you want the extra beats and type Shift-B 3e Enter.