I’ve just updated to Cubase 6 and am looking at the timestretch functionality. i followed the video below but when I timestretched tracks like this they came out as nonsense - happening at different times etc -


Can anyone advise me please or point me to some good resources?


AUdio-process-timestretch.thats the neat one

I’m new here, but I’m guessing that maybe not all tracks are set to musical mode and hence the discrepancies?

Another thing to check is that all your tracks are stamped with the correct time signature and tempo in the pool. I just tried it here and it works great. Love the Tape algorithm.


Oh dear I’m really struggling!!

I tried to select all files in music mode in the pool and then timestretch but it comes out with parts playing at different times.

Thanks I alos tried your suggestion about making sure the time signature and tempo in the pool is set consistently - I did this but found that my parts have been recorded with different tempos - possibly because I had put a tempo track down that fluctuated with the live performance.

I don’t know why Steinberg make this so confusing - It’s really frustrating in that you just want parts a and b to timestretch by the same amount but it seems to be practically impossible to execute!!


I agree it’s a little confusing, but I also think it’s partly due to not understanding how all these features work in context. I have encountered what you describe and I was somehow able to figure it out, though I can’t remember exactly what I did. I do remember changing the tempos of all tracks in the pool window and also adjusting the tempo track until all tracks played on time with the metronome. That’s when I was able to apply time stretching without issues.

Does your project play fine with the metronome?

Thanks Jose

I went away and rethought this. I actually ended up mixing down each inidvidual part (though in retrospect I could have used the Bounce Selection option). i then timestretched each track and it worked fine.

I have a new problem though . . . . I overdubbed an acoustic guitar and it sounds like it’s slipping out of time. I’m sure it’s not my playing :wink: . . . . … but seriously it’s as if the elastique pro setting on the audio is messing with the overdub . . .

Anybody had any experience of this?


I’m not very experienced with Cubase, so I’m probably the worst person to ask. However, my intuition says that perhaps there is a mismatch of time (Musical vs Linear) between the tracks. Are all tracks set to the same time mode?

It will take time. It’s easy to miss details between studying the manual and actually doing something (when you can’t see the manual). Take your time and have a good three or four runs at it and don’t on any account promise anyone any deadlines for doing this if you haven’t nailed it.
You’re probably missing just one step in the process.
Probably better to get it wrong at first than get it right as you’ll remember what should have been done later on when you, like we all do, forget that step again.
May be an idea to just print that or those portions of the manual that you find most difficult to follow.

In addition to Conman et al… why not just import an existing tune and just ‘mess’ with the time stretch… various algorithms work better in certain situations… say i need to pitch a whole track down a semi-tone to accommodate a vocalist i would use the ‘elastique formant-pitch’ algo as it preserves the formants of the track so there’s no ‘mickey mouse’ effect, if i want to just stretch a part i would try the ‘elastique formant-time’ algo… go play with em on something non-critical so it doesn’t matter if you bugger it up and you will know which algo is appropriate in which situation! bit daft trying to learn software whilst working on a project at the same time i always think…
I’m pretty impressed with it actually… slightly O/T i’m pretty impressed with VA is handling bass guitar these days… it could just do with another half octave lower to accommodate a 5 string bass though… blown away with the elastique algos though!
hope that’s of some help :wink: