Timing is off when recording


I’m moving more into film scoring and away from loop based music and so in my cubase template, I changed it from beats and bars to timecode/seconds. This change has royaly messed up recording.

First of all, if I create a cycle marker and record from the begining of that marker cycle, it starts a little bit to the left. How can I make it start right at the beginning of the marker cycle?

Secondly, lets say I record a drum loop from LA modern percussion. It sounds on beat to the metronome when i’m recoding it but when I play it back, it’s off the metronome. What’s going on here? If I try moving the clip to the begining of the cycle marker, its still of timing.


Preferences > Record > MIDI > Snap MIDI Parts to Bars is enabled by default (and on your side, most probably).

But shouldn’t that only creaty “empty space”? Becaus in his picture it looks like there are also midi notes left of the beginning of the marker… So either he played it really early or the function moved his notes to the left which would be weird, right?

Is it possible that this has to do with a pre roll or the delay you can adjust in the midi inspector. Or maybe a midi modifier?

Also: did you insert any midi fx?


Oh, I didn’t see the details. Yes, you are right.

Actually I think it’s related to the other issue here.

Thanks for the reply guys. Let me explain it better. So I press my key command to have the cursor go back to the beginning of the cycle region and then I press record. As of now, when I press record, the cursor jumps back 1 bar, has a 1 bar count-in, and then starts recording a bar earlier. How I want it to work is just to give me a 1 bar count in but don’t start record until that count in is done and certainly not to have it jump 1 bar behind. Does that make sense? I’ve attached a video. I had it working before, I honestly don’t know what I changed. I just want it to have a 1 bar countdown and start recording right at the beginning of the cycle region. @Martin.Jirsak

Try using Punch In. Set its location to where the cycle marker starts. (If the button Lock Punch Points to Locators is active, they are automatically put there when you double click the cycle marker.) This will ensure the recording will start at that location, and not earlier.

Now, about the 1-bar lead in:

  1. You can either set a marker one bar behind and use Shift-B before recording so that the cursor parks there.
  2. You can activate pre-roll, with a value of 1 measure and then park the cursor at the cycle marker’s start. (preroll will automatically start playing one bar behind). Keep in mind that pre-roll might be hidden in the transport bar. In that case, right click on the transport bar and select it. And then, you might still need to click and drag the preroll module to reveal the field where you enter the preroll value.

Oh, and you can just press play, not record. When Punch In is active and you press play, any record-enabled track will start recording when the Punch In point is reached.


Activate Count-in on the Transport Panel, please. Be aware, the Count-in is based on bars, but your main ruler is time based. So the jump back will not be really in sync with your ruler.

Ahh I think I understand. So because it’s timecode and not bars and beats, there’s no way to be in time if I need a hit point that is before a bar? Basically, you’re saying the count in and metronome will always be beat-based? So how do composers start a drum loop on a specific frame if it’s in between bars or beats and still be in time? @Martin.Jirsak



I adapt the tempo before so, the frame starts at the (any) Bar start. The Process Tempo dialog can help with this.