timing issue adding instrument track to imported audio track

I am new to this so hope someone can help.

I imported an audio track into an empty project and then added a couple of instrument tracks so I could add vst piano and bass but find the recorded vst tracks are both playing back with a slight delay.

I tried this method before under 9.5 but did not have any playback timing issues ten.

Any help gratefully received :smiley:

I am running through a steinberg UR44 and using a windows i7 laptop with 16 gig ram

So you’re actually not completely new to this because you’ve used it before in CB 9.5? :slight_smile: Anyway, it should be the same in CB10? You shouldn’t encounter any (major) delays? If you’re sure the imported audio track is fully aligned to the grid and it’s also in sync with your measurement you could also check this:

https://steinberg.help/cubase_pro_artist/v10/en/cubase_nuendo/topics/vst_instruments/vst_instruments_constrain_delay_compensation_c.html?hl=compensation

If what you’re doing is as simple as what you’ve described, I don’t see how that is actually going to work if you’re attempting to add VST instruments to align with the audio without compensating for bringing the tempo of the audio in alignment with your project; which you didn’t mention.

So if you’ve done that before with 9.5 I’d tend to believe that either you simply lucked out and had audio that just happened to have the same tempo as your project or you’re not fully describing what you’ve done at this point.

The first advice given by Nickeldome was on point in that respect. The link he provided is only applicable in the instance of real time playing of the VST which (unless I’m misinterpreting your concern) isn’t going to apply to playback of the VST with the imported audio.

Lastly, if your buffer is set too high when recording the VST instruments then it can cause a slight to extreme delay depending on your setting in which case you’d seldom if ever be able to record the VST to precisely align with the audio.