Timing off when I record

When I record and I playback notes are not played or they are out of sequence. I have ran around this by editing the notes in midi edit mode.

Also, when I cycle record the timing is off. I can’t get a clean record. I have tried asking this same question in this forum 2 times with no avail. This article that somebody recommended I have tried with no avail http://www.soundonsound.com/sos/dec07/articles/cubasetech_1207.htm

I have had this software for 6 months and cannot get past 8 bars of recording because of timing issues. I mean I could midi edit all the way through the song but that would be a waist of my time. The software is neat but I might just go with pro tools if I don’t get this timing issue correct. Look fellows, If I can get past this hump my life would e heaven. So if anybody has any knowledge of what to do thank you.

Oh, and I have pc windows XP

try in the devices menu / device setup/midi port set up / then make sure "use system time stamp for windows midi "is ticked .if that dosn`t work what sound card are you using?

Sounds like you’re just experiencing simple latency. The delay is the combined result of a bunch of things, including the speed of your PC, the make/model/type of your audio interface, your audio interface’s drivers and settings, and what software you’re using to record music, as well as how it’s configured.

If you’re just using the sound circuitry built into your computer, or a consumer add-on card like a SoundBlaster, you need special drivers to improve the audio performance. Asio4all is a popular free choice on PCs. A real audio interface is generally a better solution though.

I clicked timestamp, it still doesn’t work.

When I make a 4 bar beat thats perfect, and I copy and paste the same 4 bar beat block next to it the next block is a little off at the start of it.

What do I do?

A month ago you said:

A bit confusing.

What is the actual problem. Is the MIDI timing not as you played it? Or are the MIDI events not lining up properly when you copy/paste or duplicate them?

Providing some info on your system specs, ASIO device + buffersize and samplerate and the MIDI device you are using, also might help solving your problem.

Does this mean MIDI timing on your system is good with PT?

Are we talking arrange page?
Snap set right?
Why are we having to guess at what your doing? Try to give a better description of what and how, etc. Mind reading has yet to evolve!

OK the problem is that when I make a 4 bar beat with a piano lick as an example and I cycle it to loop it the timing isn’t right at the beginning when it repeats. Its a little off.

Asio Direct X Duplex Driver
Buffer size (SOundMax Digital Audio 2048, M audio Microoutput 1/2 2048

Sample rate 44.100 KHz

Hope you guys can help me get this timing right.

Are you working with a VST instrument?

Because with a latency of +/- 46ms it’s pretty hard to play on time.
So I would start with using your soundcard’s (M-Audio??) native ASIO driver or download ASIO4ALL instead of using the Asio Direct X Duplex Driver.
After that lower the buffersize to <512 and try again.

Na, thats not an M-Audio card. It’s the motherboards built in sound!!!

No wonder you’ve been having problems, If you invest hundreds of pounds in the software, it may be prudent to get a good ASIO soundcard too!

Or as suggested earlier, download and install the ASIO4ALL drivers, this will help you achieve a reasonable low latency response from your system.

Really all this could have been sorted months ago if you just posted more info about your system to begin with rather than have us squeeze it out of you bit by bit.

That may seem a little harsh, but really if you think about it, we have no idea about your system or what and how you are doing.

I bet you’re copying/duplicating midi notes, instead of midi-parts.

If you have a part (in your arranger screen) that is exactly 4 bars and you duplicate it, it will place the first bar, exactly behind the last bar and thus perfect ‘loop’.

But that does not work for midi, because then it will (probably) look at your grid settings and places the first midi note direct after the last note, with the timing of the grid settings.

I always have the same ‘problem’ when I do this with drum parts. Just make sure you’re grid settings are okay and just move the first note to the appropriate bar. It will work perfectly then :slight_smile: